SOLVED Rhino instant crash at loading

Since tomorrow, Rhino 7 SR18 instant crash at loading, with and Apple error
So no way to obtain System info.
When I launch the app, it appears the floating windows of Rhino, then if I open existing or even a new file, it crashes without loading the main window of Rhino…

I was on Big Sur, no major updates made … and it has always worked previously…
Since, I uninstall and reinstall Rhino from official SR18 on website.
I reset my Mac Rhino PLIST
Nothing changes
I update my mac to Monterey… no changes…
I Download from the discourse SR19… no changes
Uninstall, clean and reinstall… no changes…

And beside R7, I use R8 WIP that works…
I have no more ideas to test…

Any help is welcome :slight_smile:

@dan - any ideas here?

-Pascal

Hi Antoine -

Please post the SystemInfo data from Rhino 8.
-wim

Systeminfo.txt (5.3 KB)

Hi antoine-

Thanks for reporting this and trying what you’ve already tried (resetting preferences was a good initial thought).

and Apple error

Can you send us the contents of this error? (I take it that the Rhino crash reporter dialog never appears?)

I’d like to see if this is a regression between SR17 and SR18.

Here is a link to Rhino 7 for Mac 7.17. I’m curious to hear if you get the same crash in Rhino 7.17 or not.

Hi Dan,
Sorry i’ll be unavailable in front on my Mac until Monday, I’ll test it on monday, SR17, I’ll send you content of Apple crash, but I can warranty you, that I had few use of SR18 before it began to crash…
What I remember, the morning before it crashed is that I opened the Packmanager, and updated, Caribou, and installed Acapulco and Assembler… then i was prompted to reload Rhino… but I had no time to reload and I work on it few hours before reloading Rhino…then instant crashes…
I’ll let you know on manday
Thanks

Ah, this does sounds interesting. If you still find a crash in SR17, the next thing we’ll want to investigate is removing one-at-a-time:

  1. Caribou
  2. Acapulco
  3. Assembler

and seeing if one of those is causing the crash.

Well, I don’t think we can point the finger at those plugins. I went ahead and did this in Rhino for Mac (7.18):

  1. Launched Rhino 7.18, started a new modeling window, ran PackageManager
  2. Searched for an installed Caribou.
  3. Quit and restarted Rhino for Mac.
  4. Repeated steps 1-3 for Acapulco and then Assembler in turn.

I am unable to reproduce a crash.

NOTE: I interpret “crash at loading” as “crashes when you start a new modeling window” with the presumption that - if it crashed before that - I’d notice. Please let me know if something else is meant by this.

@dan I uninstall Rhino and reinstall it with SR17, without improvement.
Crash means this:
I click on Rhino7 icon, it shows the floating window for aprox 4 sec, and crash…

Thanks for testing this. Good to know.

I click on Rhino7 icon, it shows the floating window for aprox 4 sec, and crash…

That clarifies things and helps narrow it down a little.

Are you using CloudZoo for your license? If so, I’d like to see if this is licensing-related or not.

Let’s try this next:

  1. In Finder, navigate to the Go menu and go to the /Users/Shared/McNeel/Rhinoceros/7.0/License Manager/Licenses folder.
  2. Drag the entire Licenses folder to your Desktop so that Rhino cannot see it. This should put Rhino into a state where you have to re-login to Rhino.
  3. Restart Rhino 7 for Mac.

Does it crash?

@dan I tried and same bad issue… yes I was connecting on my rhino account to log in, and crashed on the same time, without prompt of the log in windows…
I also try to uninstall v8 to keep only V7 active on my computer…no changes…

That’s frustrating. I still don’t see any crashes logged under your name or email address, so I presume the Rhino crash reporter is never appearing (is that correct?)

I realize that the SystemInfo you sent us is from Rhino 8, so we actually don’t have a good idea of which plugins are loaded. Since we’ve already tried to eliminate the Packages (we know they are not the problem), I think it’s time to now attempt to rule-out the plugins.

  1. In Finder , navigate to the Go menu and go to the ~/Library/Application Support/McNeel/Rhinoceros/7.0 folder.
  2. Do you have any plugins other than Grasshopper, IronPython, and RhinoCycles in this folder? If so, drag them to the Desktop so that Rhino won’t see them.

If not, let’s try one more thing…let’s try starting Rhino with more verbose Console logging and see if there is a crash error in the console.

1- No plugins other than the 3 regular

2- Using Console logging I found the log file of the crash as an .ips file, I attached it in a zip file.
I also join the Console report of rhino activity
Only three lines were “yellow”, please find the screen shot (text file does not show yellow dots)

Console Crash.zip (7.1 KB)

Rhinoceros-2022-06-20-095843.ips.zip (5.0 KB)

Hope it could help…

Thank a lot

Antoine

In contact with Apple support, I also clean my NVRAM memory, and launched my Mac in safe mode, … without success, same crash

@dan

Solved !!!
I looked deeper, and additional plugins are in:

~/Library/Application Support/McNeel/Rhinoceros/**Packages**/7.0
instead of regulars ones that are in:
~/Library/Application Support/McNeel/Rhinoceros/7.0

Problem occured with IntelDenoiser, once remove from the plugin folder, I reinstall it from PackageManager, and it works perfectly like before…
No idea why it has been crashing…
Thanks for help