Solved: Rhino 6 doesn't use the Quadro k2000m


#1

Hi, I have a customer with a Quadro k2000m based laptop who just upgraded to R6 and who couldn’t get either rendered nor raytraced to work, so I asked him to upgrade his driver, but that didn’t help, so I then asked him to type in SystemInfo and send me the results and it’s obvious that Rhino doesn’t recognice the Quadro K2000m that he has.
IMO this is something Rhino should handle under the hood and it should not be necessary for a user to have to go in to the quadro drivers and either override or make a new profile for Rhino6 and tell it to not use the “let the application choose” default setting. First of all Rhino should pick the better card (can probably be done by checking both RenderVersion and VideoMemory) and the user should be able to choose which one to use from within the OpenGL settings in Rhino too. And SystemInfo should be able to list multiple GPU’s.
(And it would be good if you listed the CPU with support for multiple CPU’s too.)

Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ -“removed info”-)

Windows 7 SP1 (Physical RAM: 16Gb)

Intel® HD Graphics 4000 (OpenGL ver:3.3.0 - Build 8.15.10.2639)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 3.3
Shading Language: 3.30 - Intel Build 8.15.10.2639
Driver Date: 2-1-2012
Driver Version: 8.15.10.2639
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 2112 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp "Commands"
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp "Renderer Development Kit"
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp "Rhino Render"
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp "RDK_EtoUI"
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI"
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp "Snapshots"
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp "RhinoCycles"
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp "Toolbars"
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #2

Can you ask the customer to send the result of the command RhinoCycles_ListDevices ?

Anyway, when a certain device is selected as primary display device Rhino won’t be using that for OpenGL. The user needs to make sure that the Quadro is set to be the primary display device.


#3

Sure, should Cycles be able to use the Quadro even though Rhino uses the Intel? Or do you wonder why it doesn’t swap to the CPU?


(Nathan 'jesterKing' Letwory) #4

Raytraced should be able to use the Quadro, even if Rhino uses the Intel.

Note from the SystemInfo output that the Intel driver is really old. Please have the user update that too.


#5

Here it is:


(Nathan 'jesterKing' Letwory) #6

Raytraced should automatically pick the CUDA cards, since it is available. Can you verify with the user that the device is selected when looking at the Cycles page in the Options dialog? You could also instead ask the user to run RhinoCycles_SelectDevice and give -1 as the input to the command. Does the command say it selected the CUDA card?


#7

He has updated the drivers now and made a profile for Rhino 6 to override the GPU selection, so we are getting closer. I’ll see if this helps first.


#8

Yeah, finally after setting up a custom profile in the quadro driver and also after updating multiple drivers and a reboot it seems to work as expected.


(Nathan 'jesterKing' Letwory) #9

Yay. I love success.