Snapshots question


#1

I tried to use snapshots for the first time. They aren’t obviously working yet, right? The only things I could do was saving snapshots and deleting them, but that seems to be all for now? No animation or anything else for that matter…?

Philip


#2

So…is this the way snapshots are supposed to be (not) working for now - or is there something I don’t understand? Bug(s)?
@dan

Philip


(Dan Belcher) #3

Snapshots are working pretty well on my machine…but I would be shocked if there weren’t bugs. What’s going on for you? Can you please give specific details of the steps to reproduce what you are seeing?


#4

Ok. In that case it might be user error - or me expecting things that snapshots wasn’t designed for… I’ll test some more.

Philip


(Dan Belcher) #5

Just let us know - in detail - what steps you took, the expected behavior, and the actual behavior. There’s still work to be done in Snapshots (RH-50421, for example) and some UI Cleanup as well but at least the basics were working for me…but that’s just me :wink:


(John Brock) #6

For the sake of common ground, here’s a link to the Help file article for the Snapshot command:
http://docs.mcneel.com/rhino/6/help/en-us/index.htm#commands/snapshots.htm


#7

Thanks John! I did take a brief look at the help before trying snapshots the first time. I’ll make a new test file and go through the options I didn’t think were working the first time.

I’ll get back to you later after some more tests.

Philip


Snapshots wish
#8

Ok, I made a new, fresh file with a simple box (tilted backwards 10 degrees simulating the tilting seat of an auditorium chair - see file). This position was saved as Snapshot 01. I then rotated the box upwards (- 80 degrees). I saved this position as Snapshot 02. The views are now in Snapshot 02 “mode” (the box in an upright position).

  • Restoring Snapshot 01 doesn’t work. Nothing happens (= doesn’t restore the Snapshot 01 view) when I double click the Snapshot 01 thumbnail, or right clicking -> selecting restore snapshot, or clicking the little icon in the top bar.

  • Animation doesn’t work. Selecting a snapshot (01 or 02 doesn’t matter) and pressing the animate icon doesn’t do anything. I tried to follow the steps in the help file, but nothing happens.

  • Slideshow doesn’t appear to be working either (nothing happens regardless of what buttons I press).

  • The snapshots are in the wrong order in the panel (Snapshot 02 is first and Snapshot 01 is second). I can of course rearrange the snapshot manually, but I shouldn’t have to.

  • The tooltips for the icons doesn’t appear.

Wish: I would like to be able to specify the rotation pivot of an object (the seat in this case) by relocating the gumball to the required center of rotation.

Thanks!

Snapshot test.3dm (2.8 MB)

Philip


#9

I made a new test file. A box (1000 x 1000 x 1000 mm): Snapshot 01.
Moved the box (dragging with the gumball): Snapshot 02.
Double clicked one of the thumbnails (don’t remember which one) -> crash!

Crash dump sent.
Edit: I don’t have the file anymore (it wasn’t saved before the crash).

Philip


#10

…and now when I try to reproduce it everything is fine - no crash…

Philip


#11

Ok, this is embarrassing… User error, obviously. I had objects unchecked in the settings. Shame on me :pensive: Sorry for wasting your time.

I didn’t try slideshow with objects checked, but that’s probably working also…

However… The thumbnails do seem to shift position randomly in the snapshots panel - and the tooltips for the icons doesn’t appear.

I’ll post he wish in separate thread.
Thank you and sorry for the noise…

Edit: I do have sporadic crashes in this file also when double-clicking thumbnails.

Philip