Skeleton fattener + mesh cage morph

how did you achieve this node connections?

Hello guys,

I’m facing the same issue as @radhika.agrawal.mod1 … it appears then when we have more then 3 lines connecting at a node, their is some issues.

How you solved it ? @gustojunk, @mattgaydon, @DanielPiker ?


Fattner_nodes_issue_CC.gh (10.9 KB)

Regards,
-CC

This is not something I or @gustojunk have solved as yet. I had a look at your code @billytalent.exe to see if the misalignment was based on the order of the curves at the junction but this did not seem to fix it either.

Even tried to make a simple perfect example but this still breaks as you can see. It seems that there is a misalignment between the top of the side of the column junction and the input curves. I tried this with and without the spheres, but get the same output so it seems it’s not using the sphere to order the connection lines and edges based on UV intersections points on the surface of the sphere.

Rhino File is only for the box outlines

Misaligned Node Connection Fattener.3dm (309.6 KB)
Misaligned Node Connection Fattener.gh (23.4 KB)

thank you i will test it

Hi @DanielPiker,

First, as always, thanks for the great tool!

I’m wondering if there is an option (or how with the current component) to input a list of (corresponding) thickness values for the list of line segments, similar to what the old ExoWireframe component is capable of with input radius lists, or to Dendro’s CurveToVolume node but outputting struts instead of a rounded mesh?

Specifically, using the sphere input doesn’t seem to be a good solution for edges from a mesh made up of quad faces, where the desired thickness for the warp direction is different from the weft.

Hi!
I have problems installing the fattener.gha. I just put it in the grasshopper-libraries like other plugins, but grasshopper says it can not find it. Can anyone tell me what I can do?

On windows explorer, Right-click that .gha file , Properties , check the “delete block” option and apply.
Have you done this?

Is it possible with Skeleton fattener to made something like this?
or maybe i have to try to Inflate multiple balloons?

baloon-01

Ha, that’s an interesting challenge!
I don’t think the skeleton fattener is going to be so helpful here, except maybe as a starting point for the mesh. It will be more about inflating multiple balloons as you say, with some collision and connections between them. A bit like the example from this thread

1 Like

Dear Daniel, Thanks for your reply, i made the combination in my mind, to can build the main skeleton with lines and after, from end point to the other end point of the skeleton lines to inflate the balloons.
I will try my best. Thanks again! :grinning:

It’s slower than I’d like with all the collision checks, the proportions could use some tweaking, and I didn’t model the knot for the nose, but quite happy with how this came out


balloondog.gh (322.3 KB)

37 Likes

Wow! This was amazing! You are the best! I will try to study the code. Thanks! :blush:

1 Like

Nice love it!

Hi Daniel

Thanks for the excellent Plug-in. Have you come up with solving the issue regarding more then 4 edges?

Thanks and regards
Yutaka

Hey Daniel - Im not sure why, perhaps a bit of a brain lapse moment. But I cant manage to see the plugin when I install it into the components folder?

Is there a way I can install this?

Hi -

If you are referring to the Fatten component, that one should appear on the Mesh > Primitive tab.
-wim

hello, i can’t download this plugin i use RHINO 6 and Grasshopper 1.0.0007 this error appeared

The first error there is because one definition is using a component from the old Kangaroo, but the same component exists in the current version, so no need to install the old one.
If you let me know which definition is giving the error I can upload a version with the old component replaced.
The second error is because the Fattener is not on the package manager. In Rhino 7 the MultiPipe component replaces it, but for Rhino 6 you need to manually download and install the Fattener.gha from the file at the top of this thread.

i downloaded the Fattener.gha and copy in component folder but i cant find it in grasshopper

You might need to unblock it

1 Like