SIngle Window - still too much dead space?


#1

Nice progress. My 2-cents.the tighter the better. Here is the tightest I could get:

Would prefer tighter:

Re Sidebars - still to big for my taste as well. Would it be possible to allow the user to scale the sidebars as small as one likes, even if such creates a cropped sidebar once extents are reached? Essentially such would allow any amount of “space” customization. I used to do this with floating windows, etc.


#2

spoke too soon…so sorry

Still, can’t figure out how to make the right sidebar smaller, or cropped, without closing it completely.


#3

When I try to define the palette to show at the top, whether it is a predefined or custom I created, all I get is the Standard, and it says “No Value” in the pref pane. Am I missing something again?


#4

fwiw, rhino for mac is a full screen app now… ctrl-cmmd-F or the double arrows at the top-right of the window (and now via the view menu)

the left sidebar can scale as small (2 icons wide) if you use the heads-up command dialog as opposed to the sidebar command line…

there are also two new commands- ToggleRightSidebar and ToggleLeftSidebar which you may consider assigning to a screen edge. (Preferences-> Mouse-> Screen Edge)… or a mouse button or keystroke.

the layout i’ve been going with uses the screen edge macro for the right sidebar, full screen, skinny left sidebar, & ToggleOsnapPanelUnderCursor as a 3finger swipe… dunno… it’s pretty sweet on the 15" mbp… great use of space imo… (my desktop setup is a little different since i have larger displays for it but it’s a 1,1 macPro which is stuck on lion… it’s days are numbered with rhino moreso now than ever :wink: )

(screenshot of the entire screen)–

i guess it’s too early to really document some of this hide/unhide options but they’re worth playing around with and giving some feedback on… personally, i hope these mac specific toggle commands make it through to the final version as well as the option for the heads-up command dialogs.


(Marlin Prowell) #5

No, you’re finding bugs for me :wink:

It looks like there are problems with using a custom command set and the top tool palette. I’ll take a look at it.