Single line font not working rhino 7 win

having problem with single line fonts as object not working in rhino. the prompt for curve surface or solid is greyed out. and this happens only for single line fonts, all other fonts work fine. i tried service release, nothing reinstall fonts, nothing. the fonts are in the right place in the windows folder and in rhino7/system/.
Im in the middle of a substantial project so so far the only cure is to revert to Rhino 6.
Has anyone encountered this problem?2022-03-24T04:00:00Z

Hi Sabri /

It looks like you’ve encountered this once before, yes:

… looks like you were in the middle of something at that point as well…

Please run the Rhino SystemInfo command and copy-paste the result here.
Also, please provide a bit more details about the font, and, perhaps, the string that you’re having issues with.
-wim

it came back when i copy pasted back from rhino six onto the full model. impossible to figure it out at this stage. Last time it was a problem with the degree sign, the irony is that the degre symbol would work but none of the single line fonts i tested. Any way, here is the sys info printout.
system infos001.txt (2.5 KB)
thank you for your time.

Hi Sabri -

Thanks. That looks fine.

I’m afraid that doesn’t give a whole lot of details.
-wim

Hi Wim, im glad i keep a version 6 and 5 a backup. figuring out these glitches is like diving in witchcraft. thnx again for you prompt support

I don’t quite get though…how would you expect the textobject command to give you a single line font surface or solid? It can’t just planarSrf and extrude them. I would expect to have to DIY that from the cuves.

You are right I just need the lines for Cnc engraving . Single line font runs twice as fast on the Cnc. When I tried to enter the text which was showing in the box nothing would appear on the cursor and when I clicked to release the text in position nothing happened and nothing was recorded in the prompt lines. Very odd behavior. Three of us scratched our respective heads in dismay. The kind of moments when you are happy to have learned albeit powerless witnesses. Thankfully it seems to be working as it should now.

~Sab~

JimCarruthers
March 24

I don’t quite get though…how would you expect the textobject command to give you a single line font surface or solid? It can’t just planarSrf and extrude them. I would expect to have to DIY that from the cuves.