Since latest update Rhino is unusable because it hangs every few seconds


Since updating to the latest service release (SR10 2021-9-13) Rhino shows the busy indicator (color circle mouse pointer) every few seconds and blocks all operations in the program for some seconds.
The delays increase on bigger models (or if more Rhino models are open at the same time) until to a point where editing gets practically impossible.
This behavior was not there prior to updating to this latest service release.

System information:

Rhino 7 SR10 2021-9-13 (Rhino 7, 7.10.21256.17002, Git hash:master @ 68677dc86520a0de9485d8b8fa2e841e757733f3)
License type: Studentenlizenz, Build 2021-09-13
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 11.5.2 (Build 20G95) (Physical RAM: 24Gb)
Mac Model Identifier: iMac15,1
Language: de-AT (MacOS default)

AMD Radeon R9 M295X OpenGL Engine (OpenGL ver:4.1 ATI-4.6.20)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: AMD Radeon R9 M295X
Displays: iMac (217dpi 2x)

Graphics processors
AMD Radeon R9 M295X (4 GB)
iMac (2560 x 1440)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Canon: CanoScan
JMicron: USB to ATA/ATAPI bridge

Bluetooth devices
Apple: Apple Magic Mouse
Apple: Apple Wireless Keyboard

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.10.21256.1002
/Applications/Rhino “Rhino Bonus Tools” 7.10.21256.1002
/Applications/Rhino “PanelingTools” 7.10.21256.1002
/Applications/Rhino “Renderer Development Kit” 7.10.21256.1002
/Applications/Rhino “Displacement” 7.10.21256.1002
/Applications/Rhino “Legacy Rhino Render” 7.10.21256.1002
/Applications/Rhino “Commands” 7.10.21256.17002
/Applications/Rhino “Import_OBJ” 7.10.21256.17002
/Applications/Rhino “export_xaml” 7.10.21256.17002
/Applications/Rhino “QuadRemesh” 7.10.21256.17002
/Applications/Rhino “export_OBJ” 7.10.21256.17002
/Applications/Rhino “RDK_EtoUI” 7.10.21256.17002
/Applications/Rhino “Export SVG” 7.10.21256.17002
/Applications/Rhino “MeshCommands” 7.10.21256.17002
/Applications/Rhino “Export_DAE” 7.10.21256.17002
/Applications/Rhino “PDF Export” 7.10.21256.17002
/Applications/Rhino “IGES Export Plug-in” 7.10.21256.17002
/Applications/Rhino “Import_SVG” 7.10.21256.17002
/Applications/Rhino “BlockEdit” 7.10.21256.17002
/Applications/Rhino “Export_AMF” 7.10.21256.17002
/Applications/Rhino “Rhino Render” 7.10.21256.17002
/Applications/Rhino “Import_DST” 7.10.21256.17002
/Applications/Rhino “PLY - Polygon File Format Export” 7.10.21256.17002
/Applications/Rhino “Import_AMF” 7.10.21256.17002
/Applications/Rhino “RhinoCycles” 7.10.21256.17002
/Applications/Rhino “IronPython” 7.10.21256.17002
/Applications/Rhino “Grasshopper” 7.10.21256.17002

1 Like

Hi Wagner -

Can you confirm that running the previous version (which was that?) does not show this behavior?

I had the problem after installing the automatic update today. Prior to this I did not have this problem (I am always using the latest version, so I used the version prior to the current version without this behavior.)
Is it possible to downgrade to the previous version? Then I can double check this.

Hello, I have experienced similar issues. After upgrading to 7.10.21256.17002, Rhino has become extremely slow, pausing every few seconds, making it near impossible to do any work. I have also noticed that the issue appears to subside when I hide the layer containing external blocks. Similarly to Wagner, I did not have these issues prior to upgrading. Please advise if downgrading is possible. Thanks.

In Preferences > General, change your Updates to Service Release Candidate.
I’d be curious to see if SR11 runs better.

Any luck?

I also noticed a speed improvement when hiding layers. In my case the drawings are composed almost exclusively from external referenced blocks.

Hi Wagner -

Assuming that you are only running final Service Releases (as opposed to release candidates), the previous version is Rhino 7.9. Note that, on the Mac, you can simply rename the icon when you have installed a version so that the next version doesn’t overwrite it and you can run different versions without having to uninstall/reinstall as one has to on Windows.

I now installed SR11 and after a quick test it seem to work better.

It’s up to you, but you might want to set your update frequency back to Service Release.
It’s good to get help with the month long stability period for the Service Release Candidates, but we understand that not everyone can handle the higher risk of problems.

1 Like

Thank you for the prompt response, John and Wim. Upon installing SR11 I noticed a slight improvement regarding the issue. It is, however, still very difficult for me to to work while keeping the layer with blocks visible, as the program freezes every 10 seconds or so. (For reference, my file is relatively small – 90mb – but I have ca 300 external blocks (all smaller than 10mb) linked into the file.) When opening the file in Rhino7 for Windows, I do not experience any issues at all.

The same experience here. The SR11 (Rhino 7 SR11 2021-9-14 (Rhino 7, 7.11.21257.07002, Git hash:master @ f3e5632493b0a604bf7ed37e86dbb9b00e0ea542)) works better but still not smooth. My drawing is about 40MB and also uses a lot of external referenced blocks. The blocks are very small (80kB to 400kB).
In my case I also have several layout pages each with multiple detail views. The drawing shows building Instructions for a modular construction system so a lot of repeating parts that are referenced as external blocks (each element is a block).

What I also noticed: Opening multiple Rhino drawings at the same time has a massive negative impact. So even the drawings that are only open in other windows, but not worked on, cause to a lot of freezing
in the active drawing.

1 Like

We think we just found a problem that was introduced in V7 SR10 related to baking textures when Rhino is idling.

V7 SR9 did not have the problem.
If you are having this problem, uninstall V7 and reinstall V7 SR9:

Please let us know if this stops the problem for you.

1 Like

I think this may be fixed with
in SR 11.


I now installed V7 SR9 on my mac and this version works smooth.
I will try the SR11 again when the mentioned fix of the “baking texture bug” is included.

Thank you, John and Pascal. SR9 resolved all the issues!

Wagner, those instruction drawings look wonderful! (I’m in a similar boat, with a modular kit-of-parts)

RH-65697 is fixed in Rhino 7 Service Release 11 Release Candidate