Silly question but it's driving me nuts about extend

i have a bunch of non parallel lines in 3d space. i want to extend them all to a curve in the top view. using top view, the curve is the cutting object. how do i select the all the lines to extend them all? even one at a time, the lines still are not extending to the cutting object. it feels like i have tried all the different options with no success. have tried extend and extend curve. in mastercam, this is trim, as trim will cutoff or extend depending which side of the cutting object you pick.

Hi Tom - if the curves extensions do not hit the boundary object in 3d space, automatic extending will fail - no matter what the view is. In V5, extend works by first selecting the boundary objects, if any, Enter. then pick the ends of the curves to extend. If the extension misses the target, or there is no target,you get a dynamic extension that follow your cursor.


if i drag them out one at a time past the boundary curve they will go there, but the goal is to have them stop at the boundry object. so if the intersection point is not co-planer, it won’t use the boundary object? since there are dozens to do it would be nice to be able to select them as a group rather than one by one too.

Hi Tom - you can extrude the curve and use the result as a boundary - bigger target.


can i then select the group of lines or do i have to do each individually?

my work around has been to extend each one past where i want to go, then come back and trim each individually, which seems ridiculous.

Hi Tom - you can crossing-window (right to left) select the lines at the end to extend. Works with trimming as well.


did that but they would not select. did it all the hard way but would sure like to know if there is a better way to do this as i will be doing it lots more times in the future.

You can call Extend, enter some arbitrary distance that will extend the lines beyond the ‘trimming’ line, then reverse (i.e. crossing) window select the lines to extend, which saves the hassle of picking them individually. Then use Trim with virtual intersection enabled.

Doing things this way means that you don’t need to concern yourself with keeping everything on the same plane. Be aware that the crossing window should pass over the lines towards the end that you want to extend.

Edit: Pascal’s beaten me to it. Can’t type very quickly on this phone :frowning:

Hi Tom - does this show what you need to do?


i did get it done manually doing each one, the apparent intersection was good. if it was a choice on extend that would have been nice. what is different about extend from trim that it won’t work?

thanks pascal. looks like that would have worked. not sure why i couldn’t get the group selection to work but next time i will try the extrude. thanks for the help.

In Rhino, Trim/Extend aren’t ‘intelligent’ like they are in some other CADs. The commands can’t interpret your inputs to work out what you’re trying to do so have to be kept as sparate commands.

is it the “apparent intersection” option on trim that made it work while extend failed?

If you’re asking why Trim worked but Extend failed - Yes. Unless all of the curves are on-plane, the curves being extended won’t hit the target curve, so don’t get extended. Pascals’ suggestion of extruding the target curve to make a surface creates a ‘barn door’ target so that you’re more likely to succeed.

That said, it’s worth bearing in mind that (depending on what you’re trying to achieve) it’ll often create problems downstream if the curves don’t actually intersect, so this behaviour can act a an alert that things are not as they should be.

i’m an old school cnc user making wooden parts so i often draw roughing tool paths to avoid lots of extra cutting air and grain tearout. this is used for this purpose, not for actually creating geometry. i will keep it in mind when drawing to avoid potential problems. thanks for all the help.