Silent scaling of geometry copied between files


#1

I’m having to deal with a library of existing 2D and 3D DWG files, all of which when you open them from Windows Explorer open unitlessly, meaning in Inches, when they were made in mm. That’s not really a problem until I’m working on a new file that’s set to the correct units and want to copy-paste from the older stuff. If Rhino can’t tell the files it opens were made in mm not inches, then it doesn’t really have any business presuming to know what I want to do with units moving between sessions.


(John Brock) #2

I think you’re getting bit by AutoCAD’s unitless “Decimal” unit setting.
If you OPEN a unitless DWG, Rhino will assume MM.
If you start a new Rhino file in Inches, and IMPORT a unitless DWG, then I think you’ll get your expected behavior.


#3

Sounds like it except I normally open the DWGs though Explorer, and they always open as Inches.


#4

I have complained about this often in the past, to no avail. I run into this constantly as i juggle files in mm, cm, and meters… I hate that Rhino scales things behind my back without telling me because it THINKS it know what I want…

–Mitch