Shutlining not working

So I was trying to model some expansion joints into my model but discover that shutlining did the same but faster. The issue is that it did work for 5 lines and when applying the 6th it just stop working and the shutlining from before dissapear as well? Did I do something wrong? How is this command suppose to work; I can seem to get it to work again nothing shows.

Hi Juan - can you post the object and the shutline curves here or send to tech@mcneel.com?

thanks,

-Pascal

I am having a similar problem. I am running Rhinov5 on a VM running WIN10 when I run ApplyShutLining nothing happens. I walk carefully though all steps, all my surfaces are valid, curves are fine but nothing happens. My model is roughly 30 inches long, I am using a sharp groove with a radius of 2. I am not sure what “2” means in relation to my model so that could be part of the problem. Also I am running a trial version testing out this exact feature to see if I want to buy Windows version to run on my virtual box but if it’s not going to work I’m not sure what to do. I’m happy to share the model or at the least the part I am working on. Thanks!

I suspect it may have to do with dodgy OpenGL support on an unsupported VM, but that is just a guess.

I am running VM Ware 8.5.8. I will look in to support for GL. Is there anything I should know like what type of GL the VM “should” support.

Wondering if this article has anything at all to do with my issue.
https://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=2139606&sliceId=1&docTypeID=DT_KB_1_1&dialogID=124416581&stateId=0%200%20124430259

BTW I upgraded to VM 10 for S#!ts and Giggles just to see what happens.

So I ran a test. I created a fresh share cylinder and projected a straight line that wrapped all the way around the cylinder. I then ran ApplyShutLining at .1 radius and it worked. So I know it’s not a GL issue. It has something to do with my model. But I also tested my surfaces to see if they are valid which they were so I am not sure what I have done wrong.

Is there any way I could send you my file with just the surface I am working on so you can see why I can’t get it to work.

I think my next step is to isolate the section from all the others and see what that does. I will report back.

Hi Chad - Export the surface and the curve you are using to a new file and post it here using the icon above

image

or send to tech@mcneel.com
-Pascal

I am sending it via email because I do not know where that bar is you showed a SS of. BTW I exploded the model turned off all other layers and ran it with a .01 radius and It worked, but it looked all jagged. When I ran it on the cylinder it looked fine so obviously something is wrong that I did with my model or am doing with the command. If you’d want to chat on phone I am sending my phone number too in case that would help if not no worries this is fine. Thanks!

Not sure if this is the right place to suggest this, but in addition to the existing modes of shuttling, I would like to see one that allows for a squared gap consisting of three equal-distant sides of the gap. So you would have your curve, assign a radius but it would produce a squared gap instead.

I’m also having shutline issues. Most of the times I use it, it crashes. Or maybe it’s calculating, but after 20 minutes of calculatinf, I assume it crashed and just end the task.

What’s the issue with the shutline function? Just still in infancy / buggy state, or should I follow some implicite rules for it to behave well?

I’m trying to use it mainly for cushion creases on fabric joints. With many cushions all having many joints modeling it all is too time-consuming. Shutlining could be a real time-saver, if it worked!

For it to live up to it’s time-saving potential, some problems need addressing:

First of all it takes a loooong time to even get one line to shutline. If you’re doing lots of cushions with many curves, it can takes very long.

Sometimes Rhino just looses the shutlining, like setting it to “off” (same goes for the edgesoftening). Very annoying if you need tet all objects “on again” Especially if it starts recalculating everything again.

You can’t copy/paste nor mirror shutlines. Major drawback. Doing one cushion can take a long time. Doing the same cushion twice for left and right side of a symmetrical model is senseless. Also trying to recover an already shutlined object from another (older) file after your current file has gone weird, don’t work, since it doesn’t handle copy/paste.

Some insights into this are well appreciated, as it seems little has evolved over the past years…

coincidentally (?) I tried it on a relatively simple model yesterday but it just never really works. Maybe it does on a cube but anything more complex is likely to fail. I’ve given up on this feature. Thing is that it y needs a certain proper mesh to work well. For example if the underlying mesh is too fine and the shutlines will be wider than the smallest mesh edges, it’s not going to work.

@DavidEranen - fyi… the last couple of posts.

-Pascal

even on a cube (with custom mesh 5 mm) it fails miserably…

shutlining-fail.3dm (166.7 KB)

Here’s the thread that started on Vray’s forum:
https://forums.chaosgroup.com/forum/v-ray-for-rhino-forums/v-ray-for-rhino-public/1042699-vray-edge-texture