ShapeDiver problem with instalation

Hi everyone,
I had ShapeDiver 1.15 installed on my Rhino 6 and I wanted to install 1.16 via _TestPackageManager command. After instalation is finished I reopen Grasshopper and get following error:
Error text
Additionally, afeter clicking Ok, I received message about loadinf same files (ShapeDiver 1.15 and ShapeDiver 1.16) How to solve this? How to delete previous version of ShapeDiver?

Have you had a look at this article? ShapeDiver plugin for Grasshopper

In particular, this section might be useful:

If you had previously installed old versions of the plugin by copying components in the Grasshopper “Components” folder (on windows, usually C:\Users\USER_NAME\AppData\Roaming\Grasshopper), make sure to remove all ShapeDiver-related files from this folder. This includes, in particular:

  • BitmapComponent.gha
  • GrasshopperBitmap.dll
  • GrasshopperHyperGoo.dll
  • GrasshopperHyperGooComponents.gha
  • … and all dll and gha files that start with ShapeDiver or Sd.

Otherwise, try to go to C:\Users\mathi\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\ShapeDiver
and delete the folders corresponding to the old versions of ShapeDiver.


Second option (Roaming\McNeel\Rhinoceros\packages\6.0\ShapeDiver) worked for me. Now it works fine.

1 Like