Problems with Rhino 6 and Shapediver plugin

Hi there,

Have this problem : I just cant install in any way ShapeDiver plugin for grasshopper on Rhino 6. If Im trying to install from Food4rhino then it drops this error (pic1)


then I`m trying to open early created file with Rhino 7, and it find unrecognized objects (pic2)
2024-05-31_19h50_46
and it says that everything is installed and just restart Rhino 6 to loads newly installed plugin, spoiler it is does not install anything… (pic3)
2024-05-31_19h50_32

and then it drops two huge error (pic4 and pic5)

is it even possible to install shapediver plugin for grasshopper this days? Can I just download it in a old fashion way by using file?

The error message suggests that you have an old version of the ShapeDiver plug-in installed (1.9.4). Please try to get rid of old plugin files and try again.

Can you provide a list of files should be deleted and their location. Thing is that Rhino 6 is freshly reinstalled and has no plugins installed on it.

The problem with “Can`t open such file” still persists

so even if I somehow find all files I need to delete, I still can`t install it on rhino 6 because of this error.

  1. Try to find all ShapeDiver-related files in the Components folder (open Grasshopper > File > Special Folders > Components Folder). Pay in particular attention to this warning in our documentation:

If you had previously installed old versions of the plugin by copying components in the Grasshopper “Components” folder (on windows, usually C:\Users\USER_NAME\AppData\Roaming\Grasshopper), make sure to remove all ShapeDiver-related files from this folder. This includes, in particular:

  • BitmapComponent.gha
  • GrasshopperBitmap.dll
  • GrasshopperHyperGoo.dll
  • GrasshopperHyperGooComponents.gha
  • … and all dll and gha files that start with ShapeDiver or Sd.
  1. Just in case, you can try to delete the ShapeDiver folder from the package manager directory (something like C:\Users\USERNAME\AppData\Roaming\McNeel\Rhinoceros\packages\6.0).
  2. Instead of trying to use food4rhino, use the _TestPackageManager command in Rhino 6 and look for the latest version of the ShapeDiver package there.
  3. Restart Rhino and try again. Please let us know if that solves the issue.

Note that if you try to open files created with Rhino 7 in Rhino 6, you might still run into issues.

1 Like

Second solution worked well. After deleting from packages and opening *.gh file it suggested to install missing plugin - ShapeDiver, this time it worked well!
Thanks a lot!

1 Like