ShapeDiver - Item Indices and Surface Directions differ from Rhino


I have a Grasshopper Definition ( (28.0 KB)
) that creates a parametric container with a lid and a 3d-nameplate. The picture below shows the resulting geoemetry with default values in Rhino.

When I upload my definition to ShapeDiver, it results in the following unexpected output:

The indices to select certain faces seem to differ from Rhino to ShapeDiver. When I change the index-values via the Shape Diver sliders, the base geoemetry is displayd correctly, but the text is still not shown as in the original definition:

I added a dropdown to rotate the text:

While the text direction is now correct, the text goes into the object instead of being placed on the surface, I can only change this by flipping the surface direction in Rhino.

You can find the unedited ShapeDiver version here:


  • List Indices seem to differ from Rhino to ShapeDiver
  • Surface directions in Rhino and the ShapeDiver output are not identical

Are there any erros or suspicious tools used in my definition that could cause these deviations?
I use Rhino 7 Version 7 SR10
(7.10.21244.1001, 2021-09-01)

Iā€™m looking forward to your tips and suggestions :slight_smile:

It is not safe to hard code list items coming out of splitting and deconstructing operations. These components will not reliably send results in the same list order between different versions of Rhino, or sometimes even between the same version on two different computers.
You should add some sanity checks to those operations so you make sure you always manipulate the same object, regardless of the list order.

1 Like

Thanks for your anwser, I will try adjusting the grasshopper definition accordingly. Do you think my problem with surface directions will be solved by removing the hard coded list items as well, or are surface directions and u-v-orientations also unsafe to use without further checks?