Alignment issue, works correct with grasshopper but not Shapediver

I’ve had this definition working correctly on Shapediver for quite some time, it still works correctly with Grasshopper but using the exact same parameters on Shapediver the generated geometry is not laid out properly, it’s overlaid. I’m attaching a screenshot of the Grasshopper output and Shapediver output.
Grasshopper output


Shapediver output

I need more information in order to help.

Are you saying that the exact same ShapeDiver model that used to work now produces incorrect output? Or did you reupload the Grasshopper definition in the meanwhile? Are you working in Rhino 6 or 7? Are you uploading to Rhino 6 or 7 ShapeDiver servers?

And ultimately, in case the answers to the questions above do not get us on the right track: is it at all possible for you to produce a minimal example of a file that works in Grasshopper but produces wrong outputs after you upload it to ShapeDiver?

We are using the exact same model. There is a chance that the parameters producing the misalignment haven’t been set before, but we’ve used the definition for months.
We are using Rhino 7.
I am not sure which servers we are uploading to, but the definition was uploaded last February.
I believe I would have to forward you the complete definition which I am happy to do

Hi Mathieu.
There are a fair few parameters where the grasshopper computes correctly with Rhino but errors on shapediver. I can send you the whole grasshopper definition and list some of the scenarios where shapediver errors with the computation and Rhino computes correctly.
Logging into Shapediver it states we are on Rhino 6 servers and says we can upgrade (we have an annual paid subscription) but I can not see a way to upgrade. We use Rhino 7 in our offices.

Hi there, if you have a PRO plan, this one is only limited to R6 servers. Nonetheless, we offer optional upgrades to R7. If you’re interested, please send me an email to ezequiel@shapediver.com.

If you have any of our new plans (Designer, Designer Plus or Business), you can switch between R6 and R7 from the BACKEND section on your settings.

Best,

Got it, we will stick with the Pro plan.

1 Like

I will open a new ticket as I have updated the Grasshopper but have issues uploading, so happy for this to be closed

1 Like

Ok, got it! Just to clarify, you can stick with your PRO plan while (optionally) upgrading to R7. No need for any of our new plans.