Shapdiver and Kangaroo2 (Rhino7) Loading errors


I have a problem with ShapeDiver loading message and using ShapeDiver plugins. I have some old shapediver definition in which I used Kangaroo2.

In the meanwhile I installed Rhino7 tried to uplaod the same definition and receive message “Library Kangaroo2 Components 2.5.3 by Daniel Piker can not be used yet. The currently installed maximum version is 2.5.2. “

Than I go to List of supported third-party Grasshopper plugins page download and installed packagef supported plugins.

After restaring Rhino and Grasshopper I receive following error message (see attached txt fileGH_Load_Ex.txt (3.7 KB)

Additionally, Kangaroo2 still doesn’t work. ( IT seams that Rhino 7 have preinstalled Kangaroo 2.53?)

How to solve this problems?

Thanks in advanced,


Hi @Bojan_T
I would recommend cleaning up your plugins library and re-installing the plugins you need, including the ShapeDiver plugin**.
The exact reason for this error seems to be that there is a missing or duplicate (with a different version) GrasshopperBitmap.dll somewhere which is causing loading errors in the updated plugins that depend on a specific version of it.
**The ShapeDiver installation should already contain this dll along with Squid. If you find an additional version of this in your libraries folder, please remove it.

Regarding Kangaroo, check out this post: Kangaroo 2.5.3 not supported - #6 by praneet

Thanks I reinstall all plugins and it works now.

Please note that there are jswan duplicate on shapediver plugins package here: List of supported third-party Grasshopper plugins – ShapeDiver - Documentation and Support