Shaded Settings Rhino 7 - help please!

I have a file that I downloaded and want to know how I can make the shaded settings match the layer color. The file is attached. When I untrim the surface on the right , it matches the layer color, but the one on the left untrims and stays the stubborn color that it is.
These were part of a block that I exploded and have messed around with, and I added the red surface.
Are there some rules to what properties an object adheres to, regardless of the properties in the layer setting? I think I have them set to “by layer”, but maybe not.

I am only interested in how to fix the problem with the shaded settings. I do not plan on using the surfaces that are here.

CM59V2 Test for Vcarve Partial.3dm (254.3 KB)


depends if you’re referring to ‘shaded display mode’.

I’m not really seeing a way for that in terms of display mode:

in your image they look the same to me.

I recommend exploding and purging all blocks.

If the block data isn’t interfering, then I’d recommend double checking the display properties of the objects.

If you want them to be displayed as ‘by layer’, then I’d also recommend checking to see if the particular display mode you’re using is interfering or not.

checking your file now… looks like there’s no blocks, so that’s good.

I think you’re having an issue with nomenclature:

Not to mention a lack of intuitive GUI.

Ultimately in order for me to decipher this scenario and obtain the desired result I’d have to surmise that you want the objects to all be red?

In which case your display mode settings are probably the biggest culprit.

although I did notice these 3 entities show ‘layer mat’

but this one shows ‘custom’

Still though, It’s definitely weird how that one red one is the only fully red one hahah

So here I’m showing how I corrected part of it by assigning a layer ‘material’

And the next correction by assigning the object material back to use layer material:

and voila

what’s really weird though is the object display color appears to be the same on the list even though they’re visibly not the same.

then when you select all of them only then it will say ‘varies’

So even though it works under one setup, I’m still baffled as to why the object colors look different

[CM59V2 Test for Vcarve Partial_emod.3dm|attachment]

another weird thing is the surface UV iso’s aren’t following my display mode rules

:face_with_monocle: :thinking: :thought_balloon:

I duped an untrimmed edge and made a new extrusion to see if that would work. And yes basically something weird is going on behind those original surfaces.

I’d recommend recreating the surfaces and getting rid of those weird ones.

CM59V2 Test for Vcarve Partial_emod.3dm (2.8 MB)

1 Like

Thanks - I kind of thought it was something to do with the original objects. As I mentioned, it is more of an excercise, and hopefully a situation I won’t create in the first place with my own work. The plan is to create curves from scratch and extrude them. Enough time spent on this can’o’worms model :slight_smile:

1 Like

No need for all the above extensive explanation… it’s very simple.

The objects have per-face colors applied. Select the objects and run RemovePerFaceColors and all the objects will revert to their layer color (Red).


Thanks! That worked perfectly!

There’s still a bypass solution up there.

but I was waiting for you to say somem like

what are those :thinking:

*opening help docs and typing ‘per face colors’…

must be a new version 7 thing…


That it is…. Based on many requests in the past.

1 Like

That’s cool! I guess I read about it before but not familiar with it yet :sweat_smile: