Viewport solid black when hardware acceleration is on (Solved)

Hi all,

I don’t know if this is a problem with V6 or with my dying laptop.

V6 looks like this:

If I uncheck “use accelerated hardware” problem goes away. Weird thing also is that it says that I have Intel HD graphics 4000, when I have a Quadro something something on this computer ((Dell M4700 laptop).

Any ideas? V5 also shows same video card info but accelerated mode works well (good performace and no solid black)


1 Like

Disregard this error. That laptop ended up dying over the weekend. I think the video card was who killed it.

Well in this case my laptop is going to die soon as well. Can anyone confirm that WIP works on Intel HD4000?

Just to add to this it works on Nvidia 620M fine but when I switch to Intel HD4000 viewport is black. Rhino v5 works just fine.

THe WIP will run on systems with the Intel HD 4000 or (newer), provided it is running current display drivers.
It won’t be fast but it will work.
Report any glitches you can repeat.
The display tools are still under active development and the Intel chips are particularly difficult to support.

Here’s a link to INtel Drivers:

Well it turns out I have trouble on Nvidia 620M as well:



When I change to single color in tools options shaded then it changes to a correct display. However if I rotate the view it gets back to this weird display. All models I tested work fine in v5.

On Intel HD4000 the display is black. After disabling hardware acceleration it crashes.

Take a screenshot of your settings in Options > View > OpenGL

Please note that this is a problem only in hardware acceleration on.

You have several problems to solve.
1 - Your computer isn’t letting Rhino use your nVIdia card. That could be because your Control Panel Power settings are set to Balanced or Battery Saver. Make sure High Performance.

2 - Rhino’s OpenGL Options page should be reporting the nVidia card.
If it still isn’t after the driver update, check back with the computer maker for other updates for the system BIOS ,etc.

Thank you for the answer. Number 1 solves the problem with nVidia. This is weird though as everything worked well on v5 even in balanced mode.

It is still completely dead black on Intel HD4000 though. Changing to rendered crashes Rhino. In v5 the same model works like a charm on HD4000 even in balanced mode.
Please note that I consciously manually changed graphic chipset to intel - mainly for testing, but also because I sometimes use the laptop on battery and it saves energy.

The driver for your Intel chip is very old too.
I see I gave you a link for updating that earlier in the thread.

See if that gets you sorted.

Ahh I missed the link. I tried to update the Intel driver but it said in control panel it is up to date. Manual update did the trick and it works well now. Thank you for help.