Shaded mode, 3D geometry doesn't hide 2d lines and hatches


#1

Hi Guys, for some reson with the latest updates the shding doesn’t work anymore. It used to be that my 3d objects were hiding or infront of the 2d floorplan. Now I can see through. I used to have this sometimes when geometry is very far away from the 0,0,0 coordinate.

Any Ideas, thx oliver


(Brian James) #2

Hi Oliver,

I’m not sure if something changed in this regard in the latest SR. I personally haven’t noticed anything but there have been a couple reports of srf edges appearing through surfaces. I’m not sure if your report is the same thing but please try the command ‘Testzbiasfactor’ and change the value in the command line to see if that helps. If I could see the actual file as well that would be great. Send it to tech@mcneel.com to my attention if it’s confidential and you can share it.

Now that I look at your image again, the angle of the objects in the foreground looks great enough that you shouldn’t be experiencing an issue with zbias. Maybe you are in Xray mode? Try shaded and revert the display mode settings back to their defaults in Options>Rhino Options>View>Display Modes too to test if this is a setting change.


#3

Hi Brian,

it si not a shading mode XRAY problem. All modes are having the same problem.
I know the Z bias command, I run it with every Rhino start.
The problem also appears on all Machines her in house running the latest SR.

I think it is a bug, are your hatches hidden behind 3d Object in rnedered mode?
THX Oliver


(Brian James) #4

Thanks for the added information Oliver. Please send a sample file and I’ll try to help more and/or get this filed for the developers.


#5

Shading problem.zip(1.1 MB)

Hi Brian,
attached find a small area of the file,

Thanks, Oliver


#6

Brian,
sorry to bother you, but I found out what the problem is.

I have a 2d plan with lines and hatches on which I built the corosponding 3d Modell. At some point I used the BRINGTOFRONT command on all 2d objects.
The 2d objects are now shown in front of the 3d objects.

Now when I use SENDTOBACK the 2d geometry donesn’t go back behind th 3d Object. I thought I can use the BRINGTOFRONT on the 3d Object but that doesn’t work ether.

So I am screwd, and I need to get stuff done tonight.
Is there a command that resets the draw order of 2d objects so my 3d Object can be displayed infront again.

Plese help, Oliver


#7

ClearDrawOrder will get rid of draw order. If it is still causing you issues, can’t you just move the plan down in space a bit so they don’t have the same Z value?


(Brian James) #8

Thanks Sam!


#9

Hi Brian,
I am having the same problem of srf edges appearing through surfaces. I have read your conversation and tried all ‘Testzbiasfactor’, SENDTOBACK, CearDrawOrder, enabled 'X-ray all wires’in shading settings, and even changed the settings of ‘OpenGL’, but i’m still seing this problem. Any ideas how to resolve this problem?


#10

@Manish_Singh, make sure this is disabled (not checked). Any better when using the Shaded display mode ? If not, how far are your objects from the world origin ?

c.


#11

Hi clement,
‘X-ray all wires’ is disabled (not checked) and my objects are near the origin as well. The problem is still appearing in shaded display mode. Anything else with which you can help me out.


#12

@Manish_Singh, if your drivers are up to date and the problem persists with every scene and display mode, please post a picture and display card specs so the developers can take a look.

.
c.


#13

graphic cards properties NVIDIA GeForce GTX 970


(Wim Dekeyser) #14

Just the name of the GPU doesn’t necessarily help much. Can you post a picture of the Rhino Options dialog box with the OpenGL settings? : Rhino Options > View > OpenGL
And also information about the Rhino version: which Service Release are you running.
You could perhaps also post (a part of) that file?