Settings controlling backfaces in display modes

Any idea what setting controls the difference in “backface” representation in these two display modes?

This is a single surface, resulting from revolving a circle in a funky way:
in shaded mode, you can see that the left side of the surface looks weird - im assuming because its essentially “inside out” relative to the rest of the surface?
However, in arctic mode, the surface all seems to be the right way out…

both display modes have “Backface settings” set to “Use front face settings”. Are there any other settings that could be affecting this difference?

Hi @Sukey_Thomas

Backface settings are available via the Display Modes options
Tools /Options / …

Rodolfo Santos

Thanks Rodolfo. For both of these two display modes (arctic and shaded), that setting is set to “use front face settings”. So there must be some other setting that creates the difference in how the backfaces are seen here?


What type of effect are you after for Backfaces ?

Rodolfo Santos

I want them to look the same as the front faces, like they do in arctic mode. (No weird inside-out bits).

Hello - what you are seeing is that Rhino does not paint back faces of closed objects at all - cause they are supposed to be on the inside - the way around it is to split your object into two unjoined pieces.

(this might be a bug in Arctic… though it may also have been decided at some point that modern systems can afford to paint invisible faces and not cull them, I’ll ask… )


FWIW Arctic is just Rendered mode with all non-transparent materials set to a white diffuse, and skylighting only.

Rendered mode (and Raytraced) will draw backfaces just fine.

Thanks for this clarification
A follow-up question: is there a way to have arctic or rendered mode, but with silhouettes switched on?
(trying to please a client here…)