Setting Up Linear Workflow in Rhino and Cycles Render with sRGB Textures


I intend to implement a Linear workflow in my project. My input textures are sourced from the standard sRGB color space in Substance Painter default (*). Could you guide me on appropriately configuring Rhino Rendered and the latest version of Cycles Render for Linear processing?

*(Legacy default linear sRGB Chrominance ITU R BT 709)

I suppose the correct answer is that you should do nothing. Rhino is by default configured this way. If however you get unexpected results, I’d like to hear.

So in rendered like this?

that’s correct, yes.

Ho, no, I set my 50 textures all to 2.2 gamma manually. And must be set back to default 1

Thx for the fast answer!!

This I don’t follow, there should be no work to do on images to make them render correctly.

Under the hood Cycles is a linear rendering? And Rendered?

Yes, Both _Render and raytraced viewports are.
Rendered viewport however is a gamma corrected view.

I notice that the linear under the hood is not like the gamma corrected (to linear).
Thx Gijs!

pls share some images and a simple example to illustrate.
The Rendered view will be an approximation of the rendered end result.


Render in viewport

The default setup is clap

OK, NVIDIA denoiser was on.
I set it to off
moving the camera update and the rendering change

The main difference you see in the viewport vs rendered, is that it won’t reflect your dark floor in the rendered viewport, was that your concern for the differences?

Looks matching. My concern was more about dealing with the dark color gradient banding. It looks like 8-bit. This is a _Render

My problem was that I presumed Cycles was linear, so I disabled To Gamma default settings. To correct this, I added to each texture Gamma 2.2, and it was off.
Originally I was searching for an extended linear profile standard ACES.
I wish to match Painter with Rhino.
But it is out of this topic:

I see, the banding you mention, is a typical thing in dark areas with gradients, it’s limited by what a monitor can display. Dithering should help but cannot eliminate the issue. Adding a little noise (or not denoising) can help as well.

1 Like

Ho ok. Is not limited by my monitor. I make a thread about this: