_SetObjectDisplayMode ISSUE

Bought a new desktop pc with good graphic card and ram… but there is no way I can make _SetObjectDisplayMode work… > SPECIFICALLY TEXTURES DON’T SHOW WHEN SELECT “RENDERED” MODE.

Have also latest release of Twinmotion (shoudl that be the reason?)

This tool is incredibly useful for me when dfon’t have time to undertake full renderings for domestic clients.


Hi @Daniele_A_Diana
Start by opeinng Rhino and run the SystemInfo command and post the result here. Since it’s a new computer, my first guess would be the grapics card driver needing an update - but if the driver is already updated, disabeling Twinmotion in the PluginManager might also be worth a try. If you swith the entire view to rendered - not just a single object - do you see the textures?
HTH, Jakob

1 Like

Thansk Jakob,
I did update the graphic card drivers prior to this hiccup.

I will try the alternative solutions you mentioned (thanks)
I believe (will test) also when switching the whole scene to rendered view, textures do not show.

if problem persists will run the system info and share
using my old computer for work deadlines until the problem is solved so will need to try over the w/e

Hello - what is the viewport display mode?


hi Pascal, just tried all of them, none shows textures

hi Jakob, disabled the only twin motion plugin [ Twinmotion Direct Link 2020 ] and rebooted Rhino but the problem persists.
I am attaching the system info report now…
220306 - Rhino systeminfo.txt (2.2 KB)

Rhino 7, 7.3.21039.11201

Hello- Please also update Rhino to the current service release and see if that sorts it out - Help menu > Check for updates.


1 Like

thanks will try now and revert

Pascal thank you, it worked :slight_smile:
I will keep testing / reactivate the twimotion plugin and let you know if any other hiccupps.

1 Like

hi Pascal, not sure has to to with updating rhino realease, but now twinmotion doesn’t work… despite reactivating the plugin argh