Set the view normal to the cplane?

Hello,
Is there a simple method to align the view to be normal to the cplane that has been set? For example, I set the plane to an object, and I would like the view to be normal to the defined cplane.
Thank you.
Paul.

The command Plan should do this… --Mitch

3 Likes

Thank you, Mitch. That works. The steps I take are: set the cplane to the object, then set the view to Plan. This gives me a view perpendicular to the cplane in the viewport.
I appreciate the advice.
Paul.

1 Like

I am having trouble with this technique. I am working in a detail view. Universal Construction Planes are active (not Standard Construction Planes, Options > Modeling Aids).

I set the Cplane using 3 points in the perspective view and save that Cplane as a named CPlane. When I use _SetView > Cplane > Top, it works correctly. However, when I use the same procedure in the detail view, the view seems to be using World coordinates, not Cplane coordinates.

I’ve tried re-starting Rhino.

I’ve included 2 images below of the details views after I’ve applied the _SetView > Cplane commands. As you can see by the Cplane coordinate widget, the views are not normal to the Cplane.

Thanks for any advice you can provide.

image
image

Solved: turned on “Standard construction planes” in Rhino Options, activated the appropriate named CPlane within the detail view, _SetView > CPlane > Top.

Anyone have an explanation of why this only works with Standard construction planes? Is this a bug?

Thanks so much - this just saved me.

The standard construction planes setting still does not allow me to do what’s needed.

I often work on design components that are in relation by 45°. This makes for difficulty everytime I’ve to make some changes on the 45° angled components. I can set a Cplane to object but then I can’t easily use keycombos to navigate the associated views.

What I want to do is set a ‘world’ or whatever that reletive to the object and then be able to freely switch views that remain othagonally associated with the set CPlane.

As It works now I can use command +1/2/3/4/5 for the T/F/L/R/B views.

Shared with CloudApp

I used command+opt+1/2/3/4/5 to get the world Cplane views

Shared with CloudApp

What am I missing here?