Set libraries panel properties (c#)


#1

Hello,

I need to:

  1. Force the visibility of the libraries panel
  2. Force it to be a tab in the right tabbed panels and not a floating window
  3. Force it to automatically open a custom directory

To start I coded:

Guid librariesPanelID = Rhino.UI.PanelIds.Libraries;

but visual studio fired “Error ‘PanelIds’ does not contain a definition for ‘Libraries’” while this works:

Guid layersPanelID = Rhino.UI.PanelIds.Layers;

As to the initial directory I set it in the libraries panel settings as “Desktop”. After restarting Rhino the libraries panel shortly showed my Desktop folder, but soon went to its default folder.

Any idea?
Thanks. L


(Dale Fugier) #2

Hi @lscandella,

Are you running the latest service release of Rhino 6?

– Dale


#3

Dale,

I forgot to mention that I’m developing for Rhino 5. According to this:

http://developer.rhino3d.com/5/api/RhinoCommonWin/html/P_Rhino_UI_PanelIds_Libraries.htm

the Libraries property was available.

Thanks. L


(Dale Fugier) #4

Are you running the latest service release of Rhino 5?

– Dale


#5

Dale,

I don’t think so. I’m running:

Versione 5 SR8 64-bit
(5.8.40305.11495, 3/5/2014)
Commerciale
SN: 4-1502-0101-100-0018998-59161

in Italian and my client has frozen its production to this version.

Thanks. L


(Wim Dekeyser) #6

The latest service release is SR14. What is the reason for not upgrading?


#7

It’s not my choice. My client has tens of licences and they keep their versions frozen at the latest internal check level. They are now testing Rhino 6 and, in case of success, they will migrate from 5.8 to 6. This will not happen in the short term anyway.

No way to solve the problem under 5.8?

Thanks. L


Web browser script error
(Dale Fugier) #8

Hi @lscandella,

See if this helps:

public static Guid Libraries => new Guid("{ 0xb70a4973, 0x99ca, 0x40c0, { 0xb2, 0xb2, 0xf0, 0x34, 0x17, 0xa5, 0xff, 0x1d } }");

– Dale


#9

Dale,
It worked! Thanks!

Now the second problem I mentioned: I set the libraries panel settings as:

Show rendering contents => disabled
Show “Documents” folder => disabled
Show custom folders => enabled with a single record in the list: C:\Users\lscandella\Desktop\ :

but after restarting Rhino the libraries panel still showed its default folder:

Any idea?
Thanks. L


(Dale Fugier) #10

Hi @lscandella,

This may or may not be a bug. I know you are not using the most up-to-date version of Rhino 5.

You might want to post your usability question in the Rhino for Windows category.

– Dale