Set default font style for text (text block)


#1

Via Tools -> Options -> … , I see the possibility to set the default font style for each dimension style and also for Rhino command prompt. But I just can’t seem to locate a similar option for text blocks.

Can anybody point me in the right direction, please?

Cheers,
Sridevi


Default Text in Saved Template
(Pascal Golay) #2

No, there is no place to set that- using a startup command should help but does not- the scripted version seems to be broken as far as setting a font. As far as I can see that is a bug- you should be able to add a macro like

! _-Text 0 Font “Bondi” !

to your startup commands but I cannot make it work so far.

-Pascal


Default font set in Document properties
#3

Ah well, too bad. Our company has a new corporate font, so it would have been nice to set it as the default font for the text blocks. Anyway, thanks for shedding some light on this.


#4

Hey @pascal, good morning.

Wondering if this might have been fixed? For those of us who don’t want our default font to be Ariel, what options are there? Any thoughts?

Thank you.


(Pascal Golay) #5

Hi Cosmas - I think we should be able to get this in in V6.

-Pascal


#6

Awesome.


(Wim Dekeyser) #8

Note that in Rhino 6, the Text command uses the default style (including font) of the document, and, as such, this issue is solved.