Selections highlighting extra objects

I thought this was just me, but my coworker had the same problem.
It may be related to imported step files from engineering software like Creo or SolidWorks.

First thing’s first, after import, we explode block. There’s really no point to block instances in Rhino, from other software. Rhino doesn’t layer things well from block instances, still, and there doesn’t seem to be a good way to manage “parts” in Rhino anyway. So we explode them.
Yay, now it’s basically a regular old Rhino model, Probably with some messed up trims, because again…Rhino doesn’t handle full-assembly step files very well. My guess is because they are using different materials, so the tolerances are wildly different. Injection molded plastic over here, sand cast part over here, bent sheet metal over there…And rhino explodes.

So you’ve got your part, now you go selecting a part. Aaaand 16 other pieces highlight. What!? Ungroup, no. nothing grouped. Explode, Join. Great. Now the selection is fine.
Select another piece…and 15 pieces are also selected. What the heck!?

So this is our new nightmare. I Really hope this gets fixed ASAP.
Is it a “feature?” Please please tell me how to turn it off.

1 Like

Hello - is the highlighting a ‘shaded highlight’? If so I believe the relevant bug track item is this

The solutution, or workaround, pending a new build is to disable ‘Advanced GPU lighting’ in the display mode.


You always have the answer pascal. Thanks

I just did a fresh install on my computer (it was spring cleaning wipe day after a few years for me) and noticed that’s off by default. I went to my coworker who mentioned the problem, and he had that turned on.

And thanks for not being like Adobe or Autodesk, who would have just said I was using the software wrong. lol

Had this problem for a while when I set up a rendered display mode similar to Rhino5, for use in 6 (just a preference), with the addition of shade selected.

Thanks for the workaround, Pascal.