Selecting multiple objects while holding shift down drags objects unintentionally


In complex assemblies I often need to select multiple objects one at a time while holding the shift key down. However, in the Rhino for mac version, when I do this, the selected objects are sometimes dragged unintentionally. This is obviously pretty annoying.
Anyone any ideas? I also have friends who are experienced rhino users who are having the same problem.


yeah, this happens to me sometimes… basically, if your mouse is moving while clicking for a selection, the object drags. (which is more likely to happen when doing multiple selections since you’re moving/clicking faster)…

there’s a preference which makes it so only selected items will drag (Preferences-> Mouse-> Mouse-> Drag selected objects only)…

this will mostly eliminate the accidental drags but you may not like it if you drag things a lot… (personally, i barely drag and usually always use _Move… ymmv)

1 Like

Yeah, this one has been brought up before, it can be a real pain

One thing I have noticed though, as a work around - hit escape when the items start moving and then continue to select. Your previous selection will not be lost and you can continue…

Thanks Jeff and 2D cube :slight_smile:

Yes, that’s still happening. I generally use it when I have a number of objects to shift-select and frankly, it’s very annoying to have to stop what I’m doing and press escape and then start over again, adding additional objects.

Please fix this.

it’s user error… it could be argued that the functionality could be designed differently in order to prevent it but my point is-- it’s not broken.

another way to see this happen when trying to do something very similar:

place a bunch of files on your desktop… go around trying to quickly shift-click them for multiple selections… you’ll start dragging the files instead…

you either have to slow down &/or be more precise with the tool or, change your preference at:
Rhinoceros-> Preferences-> Mouse-> Mouse
Click and Drag
Drag selected objects only = yes

doing that will, for the most part, keep you from making the mistake.

In addition to what Jeff says, also play a bit with the “Object drag threshold” setting on the same page. If you do most of your moving of objects with the move command, you can set this very high (I have mine on 4000) and you will never accidentally drag anything again.


Ok, that’s the answer, thanks.

Try to select with shif + ⌥ + selection window (right or left)

Well, to be honest, I’ve had this without user error I’m sure. Because 99% of the time it doesn’t happen to me and then all of a sudden in one particular file it happens all the time (consecutively). Lately I have not come across this anymore but in the older versions of the Beta it surely was bad behaviour.

There are files which I’ve simply ditched or stopped working on because this happened in the past. But recently it hasn’t been a problem anymore. Can’t provide the files it happened on though, it was a year ago and they are all somewhere in backup storage.