Selecting multi curves results in accidentally moving them. annoying. Has anyone else had this problem?

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i7
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.68f99
Serial Number (system): C02H8086DV17
Hardware UUID: 5A5FADF8-216A-51E7-91D1-75020D11713E
Sudden Motion Sensor:
State: Enabled

Can you explain your steps when selecting multiple curves? I’ve tried doing so while holding Shift as well as dragging a fence selection but can’t seem to move any of the curves at the same time.

On several occasions I have been trying to select lines to join them. With the shift key selecting 2 and joining them is no problem but trying to select the 3rd results in the 1st line dragging as the mouse moves to make the 3rd selection. This happens with the mouse and trackpad.
Incidentally I am very excited by the prospect of ditching windows from my laptop. Bring on the Mac version, cheers
Jeph NealeJackman & Neale @ Artery
107 Helen St
Northcote 3070
+61 417 353

I’m not seeing this here. Can you post your file with the three curves only?

Hi Jeph, I have the same problem and can’t seem to avoid it other than slowing down. I’ve tried releasing shift after selecting a curve and then pressing it again as I select the next one but more often than not I end up moving them. You can hit escape to step backwards to stop the move command and then continue selecting the curves/objects.

I think it’s down to the speed of my laptop and size of the model, it doesn’t happen on smaller models. The one I’m working on at the moment is over 20meg and it happens often.

I’ve also noticed that snap to grid keeps popping on and off too, I’ve been careful to make sure I haven’t been touching other keys but can’t seem to avoid that, annoyingly

In Preference > Mouse, under Click and drag, try checking the “Drag selected objects only” check box. Does this help?

Ah, I’ve applied that and will check over the next few days to see if it cures the problem - thanks! :smile: