Selected Object(s) not staying highlighted


#1

I noticed this doing trims today. After I trim a section of a curve, closed or open the untrimmed part loses it highlight, making it difficult to continue with the command.

Selected curves …

After trimming the bottom of a closed circle curve …

Again showing a trimmed curve after the fact …

Is this just me or is anyone else seeing this.

«Randy

Computer info:
Software information

Software versions
Rhinoceros version: 5.4 WIP (5E7w)
IronPython version: 5.1.2015.131
WIP expiration: March 3, 2017
Language: en-CA (MacOS default)
macOS version: Version 10.12.2 (Build 16C67)

Plug-ins
/Users/jp-rhino3/Library/ColorPickers/SkalaColor.colorPicker/Contents/MacOS/SkalaColor

Third party kernel extensions
at.obdev.nke.LittleSnitch (4724) FA391ABD-2B7A-3629-9CD2-F85F7D8B5910
com.intel.kext.intelhaxm (6.0.1) 8FF2C637-0A5E-367E-B007-5B08655B1E8A
com.sophos.kext.oas (9.5.54) B52E445F-3F0B-3056-BB9D-581194C69E63
com.sophos.nke.swi (9.5.52) B9C6AF49-49A7-3666-97EE-FFA2E2E387FD

Hardware information

Computer hardware
Hardware model: iMac12,2
Processor: Intel Core i5-2500S CPU @ 2.70GHz
Memory: 20 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6770M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440, 1440 x 900
Displays: iMac (109dpi 1x), SyncMaster (89dpi 1x)

USB devices
Apple Computer, Inc.: IR Receiver
Apple: Card Reader
Apple Inc.: FaceTime HD Camera (Built-in)
Microsoft: Microsoft 3-Button Mouse with IntelliEye™
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.48.16
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None


(Pascal Golay) #2

Checking it, thanks…
@rhinorudi - So, it looks like the curve is being drawn after the pipe/edge that is there inside Trim. Am I correct that with only curves visible, this does not happen?

Hmm it does appear to actually be de-selected though, if the surface is present and not if the surface is hidden - still poking…
https://mcneel.myjetbrains.com/youtrack/issue/MR-3025
-Pascal


#3

From what I could see yesterday in that model it would be normal highlighted when only curves. The pipes were made from the small circle with a Sweep1. I then did a circle tangent to 3 curves to get my trimming curves.

It gets deselected visually, but I can continue trimming with the curves.

This has happened sporadically for me with curves on edges for sometime. This time it seems over-zealous. Maybe it was a trumpism yesterday!

I will open the model in a bit and have another look.

«Randy