Trimming in Rhino 7

Hi, I’ve had Rhino 7 for a while but only noticed this issue with the last update. In older versions of Rhino, when trimming, only the objects used to trim remained selected while the objects being trimmed remained unselected. I got in the habit of of drawing a cutplane to trim something and then simply hitting delete to get rid of the cutplane after I was done using it to trim. In Rhino 7, the objects being trimmed become selected, so that now when I hit delete after trimming, everything involved is deleted. I realize this is relatively trivial, but old habits die hard, and it keep having to back up when I realize this has happened too late. Is there a quick option in the settings where I can change it back?

Thank you

Hello- it should work like this: If the cutter is preselected when Trim is started, it should stay selected when the command is done; if post selected, that is, the command starts with no selection, then selected cutters are deselected at the end of the command. Does that make sense with what you see?


Thanks Pascal,

What you’re describing is what I’m used to but not what I’m seeing. If I preselect a cutter, any object being cut becomes part of the selection in addition to the cutter and remains selected when the command is done.

Hm - does it do this with just say any two intersecting curves? Can you please run SystemInfo in Rhino and copy/paste the results here?


Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15001, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 11-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 457.51
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-22-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Orca3D V2\Orca3D.rhp “Orca3D”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Now that I’m playing with it, I think it might only happen when i’m trimming a polysurface. It seems to work normally when trimming single surfaces and curves.

Hello - I guess I’d try with Orca disabled and see if that makes any difference - in Options > Plug-ins page, disable Orca, then close Rhino and restart it… any different?


Still happens with Orca disabled.

Hello - Can you please post an example object(s)? I want to be sure I am looking at the same thing as you.


Tank and Cutplane.3dm (96.6 KB)
Hi Pascal,

I uploaded a sample polysurface and a cutplane. If I preselect the cutplane, then trim the polysurface, the polysurface becomes selected when the trim command is over…it doesn’t show up as highlighted (no yellow border), but if I hit delete or use the move command or something like that, it gets deleted or moved with the highlighted cutplane.

Wow… how weird - that does not happen here… Thinking…

@drybovich - I just noticed a comment from a developer about fixing a highlighting problem in Trim - does the problem occur for you if there are two polysurfaces to trim?


Hi Pascal,

Sorry for the delayed response. One of the recent updates seems to have solved the issue. Everything is working great. Thanks for your help.