Select element in the Revit Link

I have a question here. Is it possible to select/pick the element in the revit link files.
example: I’m working in architectural model and i also have a structural file that link into architecture file that contains such as column and beam.

What I intended to do is using RiR to select the columns so i can use it in grasshopper. Thank you

You might find this thread helpful

the problem with this is when i tried to select multiple element, my revit will be crashed. Maybe its still not stable yet. i dont know, but anyway thank you for the reply

We already detected that problem, but thanks for reporting it.
A fix for this will be included in the next Rhino WIP release that use to be each Tuesday.

But yes, if you have linked models in your project the ‘Geometric Element’ parameter context menu should look like this.

1 Like

Thanks again for such an amazing respond.
Glad to be part of this community


1 Like

We are glad to have you here as well :slight_smile: Thanks for the support.

1 Like


The fix is available.
You will need to update Rhino WIP and Rhino.Inside Revit.

hi @kike , I am having problems with selecting linked elements is certain Revit links. I am able to select the elements from the model that uses shared coordinates, but for the links that arent using shared coordinates, I am not able to… I get the message below. To be honest, I am not sure what is causing this problem, but so far this is the only difference I noticed between the models. They all live in BIM360. I might be doing something wrong tho so any help is greatly appreciated. :slight_smile:

Any suggestions?


1 Like

I am having the exact same problem…anybody any suggestion?

I can confirm that we seem to have a bug with linked elements:

  • I created a simple linked model with a series of walls
  • Selected a few elements using RIR with no issues
  • Changed the link to Publish Coordinates and rotated the link instance
  • Selected more elements in RIR but now the elements show up in different branches

@kike Would you mind taking a look at this?

Last release should fix this.
Please update your Rhino.Inside.

1 Like

Know this is an old post, but did you ever find a solution to this? Select element in the Revit Link - #8 by danijelruso
I’m getting the same error message in Revit 2022. The models are also in BIM360 but they do have the same shared coordinates.


See below to query the linked document from BIM 360