Scripts crowding command line at Rhino startup

Hi All,

I have scripts and tools, many found here on the newsgroup, shared by some of you, many build by Pascal.

And when I start Rhino I usually have to hit ESC a few times since a bunch of scripts of tools that I’ve use endue nagging me at startup.

here’s what I mean, look what happens when I start Rhino:

In this case some of those command line prompts are form scripts that endup being auto-added here:

If I delete them from this list the problem goes away, but the minute I run any of those tools again, then they come back.

IS this cause by the way the scripts where written? I also think that if they are not running at startup then the tools will not work when invoked, and I have to manually drag the script form its folder to Rhino’s window. What’s a good solution for this problem?

Could we have one option that tells Rhino: “when you run all these scripts that you need run at startup, don’t you get needy and don’t you even think about asking for candy at the command line. You just run quietly and be ready to do work”



not knowing about any of these scripts, also not the pretiest to edit, but you could make a custom toolbar and just create one button per script.

yes, I do have one button per script. In some cases the entire script is in the button itself, like here:

In some other cased then invoke the script from my scripts folder, like here:


Hi Gustavo - generally the scripts I write are designed to be dragon-dropped and should not do anything at startup, however, there is also generally a line in there to run the script directly, like from the editor, for debugging - if that line is not commented out, then the script will try to run at startup - it is entirely possible that in our back and forth getting the scripts right, I sent you de-bug versions with that line of code active. Send me what you’ve got and I’ll check.


hi Pascal,

That makes sense. I send you a couple to test via message. THX