Q: How to prevent autorun a script while Rhino is loading?

rhinoscript
settings

(Petr Benes) #1

Hi
I downloaded a script “HarmonyDistribution.rvb” and linked it in Rhino Options - RhinoScript - to be loaded when Rhino starts.
But it automaticaly autoruns the script so it is always waiting for some input and prevent Rhino to start using normaly.
I have to click into the comand line and hit Esc on keyboard to interupt running scritp and let the Rhino finish loading.

Is there any settings or workaround how to prevent this? I would like to call the script by clicking on a button.
I create the button for that already.

Thank you for help.


(Wim Dekeyser) #2

Normally you just enter the following on your button:

! _-RunScript ( < paste script here > )

I haven’t looked into the internals of that script but here’s a thread discussing that one:


(Petr Benes) #3

Here is the start screen while Rhino is loading. Please see the command line, there is a running Script waiting for some input and prevent to Rhino load. The welcome screen with the loading green stripe is infinitely remaining. How to prevent the script to autorun while Rhino is starting?

Script settings:

Button settings:


(Petr Benes) #4

Thank you
I did it like that, maybe there is something wrong in the script itself, but it is out of my skils to find what is wrong :frowning:


(Wim Dekeyser) #5

That script calls itself right away so when you launch Rhino, the script is not only loaded in memory but also run (and activated to ask for input).

I don’t have time to dig into that script but a quick glance tells me that it probably should work if you comment out or delete the line that says

HarmonyDistribution

in

option explicit
HarmonyDistribution
sub HarmonyDistribution()

at the start of that script.


(Petr Benes) #6

That was the trick!
This helped.

Thank you a lot.