Scale option in import is beyond understanding

Hi,
Import is messed up it no longer opens the dialog box with options but you have to use the -_import option, then you get the dialog.

And then the killer, Rhino asks me for numbers, why ask me for numbers what the hell does that mean who implemented this it’s so none user friendly.

What’s wrong with options:
Original file in mm
change to your chosen units here
Do you wish to keep the object same size or rescale
RM

1 Like

Hello - you can import with the physical size of the object unchanged, or the dimension numbers in the current file units unchanged.

-Pascal

Hi Pascal,
Ok but what if you get a file in mm accidentally and must work on it in feet? Because what happened was this file was somehow saved to mm and when I got it no importing made it the proper size? I don’t think its a scale thing maybe an option has been lost that we had in older Rhino? I think it was “import file but keep model numbers the same?” Where 10 mm was read as 10 feet?

Am I supposed to supply the numbers that would do the translation? If so that makes no sense.
I know this is a can of worms because it depends on what one wants scaled. I thought by now there would an import with “scale types similar” to the templates, this way I could select any types to scale to when I import and I think the above option was stripped out?
RM

Hi Roland,
So far I’m not seeing anything strange going on.

I start with a new file from the Feet built-in template and import another file that is in mm.

If I just use Import or drag’n’drop the file onto a viewport, the geometry gets correctly scaled automatically.

If I use -Import and browse to the file, I get to pick if I “wish to keep the object same size or rescale” and “Keep <ModelSize>” is the default.

I see the same in both Rhino 5 and 6.
image

If you have a specific model that is causing problems, please send that over for us to take a look!