Save duplicate suddenly works differently


(Marinus) #1

Hi guys, normally when I use CMD+Shift+S I always got a duplicate file with in the header of the document, the same file name and I could edit the filename easily to create consecutive names. It would always save this file in the same folder as the previous file I worked on where I used the CMD+Shift+S key combo.

Now, since a few days it’s been behaving differently.

The new file I get is called “Unsaved Rhinoceros Document.3dm” and it’s placed in the folder “Autosave Information” by default.

Is there anything I can do to turn the save as a ‘Duplicate’ back to the way it used to work or am I having some error in a config file or something?

I hope someone has the answer, because this is crippling my workflow. Every time I want to make a backup and work on in a new file I now am pulled out of my focus for having to browse my computer to put the new file into the correct folder and copy the name in the previous window and paste it in the new one and add a higher number to it. And I hope this doesn’t sound strange O:)


Rhino 5 for Mac Update 5.4.2
(Marinus) #2

Great, now I can’t edit my post; error:
The tag “unhandled” may only be removed by staff.

Anyway:

Software information

Software versions
Rhinoceros version: 5.4.1 (5E409)
Rhinoceros path: /Applications/Rhinoceros.app
IronPython version: 5.1.2015.131
Language: en (MacOS default)
macOS version: Version 10.10.5 (Build 14F27)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4850HQ CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1680 x 1050
Displays: Color LCD (258dpi 2x)

USB devices
Apple: Internal Memory Card Reader
A4TECH: USB Device
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.4.2 310.41.35f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


Discource: Bug in editing a post?
(Marinus) #3

Is there really no one that has any idea how to change it back to the old way it used to save? This is driving me completely nuts…


#4

I didn’t like it either. Then again, maybe I just don’t like change.

I suppose the question is whether the change is intended by the developers, or an error?


(Dan Belcher) #7

Hi, sorry for the slow response…I realize now we never circled around and acknowledged that this was broken. MR-3225 is fixed. This should be back to the way things were in the 5.4.2 update.


(Marinus) #9

Hi Dan, thanks for coming back to update on this question! Updated and now it works like before, great. Thanks a lot.