Rotate Snapping bug


I ran into an issue where I rotate an object, yet when I Osnap ( projected) to set the start angle, the startpoint seems to snap to the nearest ortho axis.
Can anyone tell we if I’m being dense or this is indeed a bug.
V5 works as expected. testfile: odd_rotate.3dm (442.4 KB)

screen recording that shows the wierd jump:

the video semes buggy itself here’s a youtube link:


Hi Willem,
I ran into this as well last night a real show stopper hope they release a new beta with a fix for this soon.
You can also see it when doing rotate 3d, where rotating around the z axis in a perspective viewport works but the problem Willem spoke of can be seen on the x and y axis if you try to 3d rotate an object around those.

1 Like

I see that too. Might be a side-effect of the new behavior to show ± degrees instead of e.g. 10º CCW and 350º CW.

See RH-35630. This fix is out for testing in the latest WIP… @dale?

Hi Willem - I see something is wrong - it looks like the last used rotation angle is incorrectly being taken into account. Does it work if you open Rhino and try, first thing?


Hi Pascal,
Nope: in a new instance I draw a slightly slanting box and try to rotate.
Same behaviour unfortunately.
It’s a serious bug, even with large angles:


Yep, I got it…