RiR Load Error - Unable to load DLL 'rhcommon_c':

I have been working on a few projects using RiR and I recently downloaded the latest WIP and RiR packages. After the install Revit is throwing the following error.


I cant seem to figure out why I am getting this error on certain projects, and am curious if anyone is having similar issues or seen this before? I have spent some time looking through the forums in hopes to find a solution, but was unable to find this particular error. I have taken a few steps to try to troubleshoot it based on other startup issues.

- Reinstalled the latest WIP and RiR
This what done today and still throwing the error.

- Opened WIP outside of Revit to verify license works
Rhino 7 WIP and GH worked fine outside or Revit and the key matched my Rhino 6 key.

- Tested Various Projects (Central & Detached) both in Revit 2019 & 2020
Only certain Projects was I getting this error. 2019 seemed to have no issues, but certain projects in Revit 2020 were throwing this error, Specifically ones that I had used old builds of RiR on.

- Spoke with my IT department about recent plugins installed, specifically PyRevit
No plugins have been added, and I do not have any PyRevit Plugins installed on my machine.

- Opened RiR without plugins
This worked and RiR opened and ran fine. I also found if RiR was opened prior to opening the projects that were throwing the error it opened just fine and worked just fine.

I can workaround the error, but opening RiR before the project, but I’m hoping someone might have a solution/explanation of this error.

Thanks you!


Hello Greg,

quite of a late response here, but it may still help you or someone else.

I had the same issue and that was solved by repairing the installation of my latest Microsoft Visual C++ from Control Panel.

From Control Panel, Uninstall or change program, than right click, change, repair.
I did it for both x64 and x86 version.

I did this after reading about a similar problem from 2012.

1 Like

I’m running into a similar issue. I am trying to create an application that uses Rhino Inside. I’m getting the same error. I’m running Visual Studio 2022, Rhino 7. I’ve installed Rhino.Inside Nuget package. I’ve had to copy the RhinoCommon.dll file into the target directory. I tried copying over the rhcommon_c.dll file into the target directory as well but it didn’t work. I tried reinstalling the latest C++ but it also didn’t work.
Any advice would be greatly appreciated.


Hi @charlie_portell,

There isn’t enough here for us to provide much help. But you should not be copying the dll’s included with the NuGet package around - especially to Rhino’s system folder.

Rhino is a 64-bit app. So make sure your .NET projects targets x64, not AnyCPU.

– dale