Rhinocam z difference in gcode

Hi!

Thinking to buy old cnc.
Trying to test it. It is opereted through mach3 and rhinocam in rhino4.

I have some problems.
Cutting depth set to 15 but g-code shows 14. It is always -1 as set.
Why?




And one more question:
I’ve read what is this G43. I dont’ understand all and Mach 3 says it is:


Is there some setting I have to change? I deleted the row and it worked “normal”. But it should not be like that you have to make some manual changes to the gcode…

Thanks

The end depth (-14) is going to depend on where the original profile is located in Z (maybe it’s at +1?) and whether you have set the profile at the top or the bottom. With what you show, it’s impossible to tell. You also need to check if you haven’t set some kind of Z offset in the tool definition. This may also be related to your second question, the G43 command sets the tool length compensation on certain CNC controls. Yours (Mach3) may not support that.

In general if the postprocessor is set up right (another thing to check) the G-Code will be correct, so you need to check all of the above. If you have an official version of RhinoCAM, Mecsoft support can help.

Hi Helvetosaur!
You were right. There was offset in tool settings. I changed it once before but then there was no difference because I just pressed the “ok” button, not “save to tool”. Now it works because of “save to tool”.
Thanks :slight_smile: