Rhino8 and Picture sees image size not as entered

Hi, V8

Rhino8 has Picture not PictureFrame,

V5 was this:-
I always had to copy the image width in Photoshop such as 17.365 inches to clipboard
Then run command PictureFrame, browse to the raster image,
It asks ‘first corner of picture frame’
click and then it asks ‘length of picture frame’
I ctrl V and Paste width into command line,
and I get the image at that size. I am able to rotate it with mouse BUT ITS SIZE IS FIXTURE.
I hold shift and it goes level then click and I have my picture 17.365 inches wide.

I do that in Rhino8

Picture,
It asks ‘first corner of picture’
I click,
It asks Other corner or length
I ctrl V and Paste width into command line,

Instead of a stable non changing image size as I always get at that moment, its able to go to whatever size my mouse is moving,

It then says
Width, press enter to use length.
Now width and length are the same , whilst height is top to bottom.
I need it to adopt the width I pasted in,
I press enter, the resulting image measures 59.13 inches wide, not 17.365

This process has completely changed and I dont have my image at its native size.

In fact it feels 'wild, with image going allsizes whilst I hold the mouse.

As I use PuctureFrame thousands of times, I need to solve this instability.
Why when it worked great is it now like this ?

I have someone coming today to show them how to use Rhino 8 with plans placement and shrinkwrap on photogrammetry yet this happens and the shrinkwrap has made a wasp nest and failed on a wall.

Steve

This behavior apparently changed in Rhino 6 when it went from PictureFrame to Picture, it has been this way since then. The workflow does seem somewhat broken, but is still usable. If you place the first corner, then type a length constraint, the length constraint will be obeyed as long as the mouse cursor remains within the image height in Y. If you pull it up further than that, it gets bigger. That actually should not happen IMO, I do not see the usefulness of this.

If you want to place an ortho-oriented image you can simply place the first point, let go of the mouse, type a length and enter (without moving the mouse).

You cannot rotate it in standard placement mode, even with ortho off. If you do want to rotate it while placing, you need to use the 3Point option in the command line.

Hi, it worked fine in V5, wish things that worked didnt get broken.

so now

  1. copy width of image in units used in photoshop
  2. run command Picture
  3. browse to the image
  4. click in an ortho view
  5. LET GO OF MOUSE
  6. paste the value in and hit enter
  7. the image will sit perfectly horizontal with no need to use shift and click

One can now move the image to where it is required, then scale it 2D to size required.

is that now correct ?

Cheers

Steve

It’s not broken, it’s just different.

Did you try it?

Hi,
v8
made an image 10inch wide in Pshop, saved is as test10inch.
in v8 run command picture,
click and browse to the image,
click on page (grid snap off)
ctrl v the 10inch width not touching mouse after initial click,
hit enter,
measure image, 13.49 inches

oh dear.

Steve

You are correct, that does not work. There is definitely something confusing about how this is set up.

To make it work either:

  1. use the 3Point option at the command line (you can even make a macro), or
  2. make sure that once you have set the length, that you pull the mouse cursor inside the shown image area close to the first point (and see that it stops shrinking at a certain point) to click to set it.

The first (3Point) option is probably your best bet.

Hi,
I absolutely hate it when something that worked fine gets meddled with and no longer works easily, if at all, why meddle with it ? Its taking up my much needed time trying TO PLACE AN IMAGE NOW. We buy upgrades for betterment, for things to help us more.

McNeel note this…it worked fine in V5,
I hate it when its been changed, why ?
if it worked fine, why change it, now look at it, its a mess.
its not broken, but if something that worked fine no longer has any ease of use, in my book its broken.
I am sending this to McNeel as I use it thousands of times, and its not right at all now.
Adding it to the list of things thread of what doesnt now work in V8.

Until this is sorted I have to go back to V5, as I can’t place an image…(its ‘sort of’ broken !), unable to make use of my purchase.

anyhow lets do it again using 3point.

  1. copy image width in inches from Pshop to clipboard.
  2. select an ortho view
  3. run command Picture,
  4. browse to image and select the image and click ‘open’
  5. it asks for first Corner of Picture
  6. select option 3point
  7. command asks ‘start of edge’
  8. click on work area and then dont touch mouse
  9. it asks for ‘end of edge’
  10. paste the value in from clipboard using ctrl V and nothing changes at all, no image shows
    11 hit enter and it says orientation, but to what, see nothing, move mouse nothing.

so at stage 8 try instead:-
8. click on work area and move mouse, see a picture going any size
9. it asks ‘end of edge’, so ctrl v paste the value of width from pshop.
10. it now fixes width of image and user can rotate image about first click
11. its still asking ‘End of Edge’ so hold down shift to control rotation to horizontal and click.
12. now it is flipping about the horizontal axis at first click.
13. click above that axis and its done.

it measures 10 inches wide, HOORAY !#

however thats 13 steps to do what V5 did in …9 !

  1. copy image width in inches from Pshop to clipboard.
  2. select an ortho view
  3. run command PictureFrame,
  4. browse to image and select the image and click ‘open’
  5. it asks for first Corner of Picture
  6. click on work area
  7. command asks ‘length of Picture Frame’
  8. ctrl V paste the value
  9. hold shift to make it horiz and click.

job done

only 8 steps to simply place an image. In fact 7 for the actual command.
V8 took 11 for the actual command. and its complex.

I vote for V5, and sanity.

Steve

Oh puhleeze…

It’s.Not.Complicated. It’s.Not.Life.Threatening

Make a macro

! _Picture _Pause _3Point

That will work just like V5.

Hi,
all day trying to place a picture…v8 :rage:
someone meddled with a simple command.

Do you have 1to1 in the options after ok-ing an image ?

McNeel suggest use that, I dont have such an option yet am up to date…

that macro, just how do I have it that its there without having to type it out, make a button for it to right of my other buttons ?

would such work during a command ?

Are folk running Picture going to need to know this, and make a button, as without this the picture is not the size it should be.

This should work straight off the bat. Very bad to have to consult threads to place a picture…true !!!

and where is 1to1 or short cut t that this command is supposed to have ?

Steve

There is a youtrack.

Using -Picture will give the expected options in the meanwhile.

" The Picture command determines whether or not can do the 1To1 option based on whether or not the image has DPI information (BITMAPINFOHEADER.biXPelsPerMeter and BITMAPINFOHEADER.biYPelsPerMeter). For this image, these values are zero, meaning the image file contains no DPI information."

RH-81665

Hi
Thank you Japhy.

HYPHEN PICTURE not Underscore Picture.

THIS WORKS, AS V5
ITS SIMPLE, DOES THE JOB.
HOORAY !

EVERYONE PLACING PICTURES TAKE NOTE.

To place an image do this:-

-Picture
browse to image, hit open
click in an ortho view
enter width, hit enter
click again
done !

5 steps, not the crazy 13.

One Happy Bunny.

This needs to be a sticky.
How does one get these simple steps put up as a sticky ?

Steve