Rhino7 Freezes up

Rhino 7 freezes up and I have to crash recover with CTR+ALT=DEL to free up Rhino7, loose all my work and restart.
I have just upgraded from Rhino5 to 7.
Rhino5 was running smoothly without and freezing.

Please assist in fixing the problem.

Hi @nic2
First thing to do is:
Start Rhino
Type Systeminfo in the command prompt
Copy the resulting text and paste it in a post here on the forum - that will give everybody a better idea of what might be going on.
My guess - based on experience - is that you need to update your graphics card driver.
HTH, Jakob

Rhino 7 SR8 2021-7-15 (Rhino 7, 7.8.21196.05001, Git hash:master @ 45c1fd6dc85c7c1cce8c0bbe6f3e16481ae9abfa)
License type: Commercial, build 2021-07-15
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

Secondary graphics devices.
Radeon ™ 530 (AMD) Memory: 2GB, Driver date: 5-5-2020 (M-D-Y).
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

Desktop is using the slower, less reliable integrated graphics device and probably needs a configuration change.

There are 2 monitors detected, but none of them are connected to any of the accelerated graphics video ports.

  • Recommended: Unplug one of the monitors and plug it into one of the video ports on this device:
    [Radeon ™ 530]
    …and then using Windows’ Display Settings, make that monitor the “Main Display”.
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 0.0 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 5-5-2020
Driver Version: 27.20.1016.1
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\RhinoCAM 2021 for R7\RhinoCAM 2021 For Rhino7.0.rhp “RhinoCAM 2021 - The cutting edge CAM plug-in for Rhino 7.0 from MecSoft Corporation”
C:\Program Files\Rhino 7\Plug-ins\RhinoCAM 2021 for R7\RhinoArt1FileExporter For Rhino7.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 7\Plug-ins\DATAKIT\Rhino7_Import_x64.rhp “Datakit_to_rhino7”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\export_STEP.rhp “STEP Export”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @nic2
First of all, it looks as if both your monitors are connected to you somewhat weak integrated graphics card - is there a reason for this, instead of using the more powerful Radeon card? Also… although the Radeon is more powerful than the Intel, it’s still somewhat on the light side for what Rhino 7 requires (4GB VRAM minimum) and also there’s a more recent driver available here:
HTH, Jakob

Hey Jakob
Thank you for your comments and assistance. I have to say that since Rhino3 I have never selected any alternative display devices than the PC defaults. Actually I do not even know how to set different devices for display.
I have however installed the latest Radeon driver as per your suggestion, just need to figure out how to set that then as the new default display choice.
Thanks a lot mate

Hi Nic -

For starters, I would plug the primary monitor into the Radeon card instead of using the port that it is connected to at this point. You’ll have to restart Rhino to see if that has changed anything - paste an updated SystemInfo if you want us to take a look.

Also note that the 4GB recommended minimum VRAM is for 1 monitor only. For 2 monitors, you’ll want 8GB. Have you tried using only one monitor to see if that improves things?

Hi Wim
Thank you for support.
My challenge is that my system is a Lenovo All in One, so no option to connect to another card as far as I know.
I have the second screen plugged into the HDMI port on the All in One.
I have to add that I have been getting errors from my 3D printer software about OpenGL and the VGA card, could this also be partly to blame?


Hi All
I have now been limping along with Rhino 7 for over a week. I have increased the VRAM without eliminating the freezing of Rhino7. I have to CNTR-ALT-Delete and kill the Rhino process at least 5 times a day to work. This is not what I expected from the upgrade.
What is the process, and loop holes, to remove this version and migrate back to Rhino 5 that was working perfectly for years.
I am looking forward to your ongoing support

The Capture viewport to file or Capture viewport to clipboard command results in a black screen only.
Nothing gets captures?
Any comments on this?

Hi Nic -

Those are just more symptoms that indicates an issue with the hardware.

Could you post an updated SystemInfo?
Did you try running Rhino with just one monitor?

Upgrading to Rhino 7 from Rhino 5 means that you still can use Rhino 5. If you want to return Rhino 7 or have other questions related to licensing, please contact sales@mcneel.com directly.