RHino7 for Mac - Blend Edge not working as it used to

I was on Rhino 5 before the current version.

Blend Edges replaced Variable Radius Blend on the latest version, I think I am right about this. My problem is, the Blend Edges is not working like it used to. For years I have been adding radius’s to edges exactly like these without a hick-up in Rhino 5. Many very basic clean edges on surfaces are not working and I get a message that there is a creased surface. Is there a tolerance setting or something to remedy this? I have attached a picture of one that worked and one that did not.

Hello - run the DivideAlongCreases command > SplitAtTangents =Yes on the input object, then BlendEdge - any better?


Wow, that did work. SO what am I doing with this Divide Along Creases? When I run this, my entire object is selected - 1. must I run this all the time? 2. What is this doing and does it cause problems in future editing of the object???

Thank you for your help!

Hi Tom - finding the rails for filleting and blending at edges requires that the input objects’ surfaces be offset and intersections calculated. If the object has surfaces that are curvature discontinuous, that is, internally only tangent but single surfaces, the filleting can fail at that point. DivideAlongCreases splits these surfaces into multiple surfaces (polysurfaces) at the tangent locations, which allows the whole process to work better.


1 Like

Thanks again Pascal!! You know a lot about this program!