Rhino7 Blurry Textures In Rendered View (But Not in UV Editor)

The image I am mapping looks perfect in the Rendered View when I am in the UV Editor mode.
But as soon as I click apply, the texture becomes extremely blurry in both the Rendered View and the Final Rendered image. Anyone have a guess as to a fix?
See Images.



Can you share the file this is happening in?

Spiral Test.3dm (6.5 MB)
Sure thing. It is for my job. So I have removed the piece of furniture because there were no problems with the mapping on the rest of the set. Just the “spiral pattern” sweep.

Right, in v7 this is happening because of baking of the texture, especially in the case of Rhino Render (and Raytraced).

For Rhino Render you can set under Rhino Render Advanced Settings section in the Rendering panel the Texture Bake Quality to say High or Ultra, this will result in more memory being used while rendering. This should result in better rendering quality. I don’t think there is much to be done for Rendered mode, although @DavidEranen may know some trick there.

Note that this is all better in Rhino 8 - no baking happening for Rhino Render, the original texture will be used.

Rhino 7 with ultra bake quality

Rhino 8:

Hi @Drew_Haeffele,

We have a maximum default texture size limit for baked textures in Rendered mode. You can change the default by going to Tools → Options → Advanced and searching for AdvancedTexturePreviewMaxResolution and changing the value from 2048 to something larger, e.g. 8192. After this, restart Rhino. It still might not look good enough, but it should be better. Keep in mind you might have to wait for a little while before the highest-quality texture has been baked.

The unwrapped model is taking up only a small area of the UV rectangle region, which is making it hard to see detail in the final baked texture. As @nathanletwory already said, Rhino 8 is much better in this regard due to a number of fixes and improvements by @Jussi_Aaltonen.

-David

Thank you both for the insight @nathanletwory @DavidEranen !