UV Editor Apply Fuzziness

Hi everyone,

I’m just starting to learn about rendering with materials and was having some success until this hurdle arose.

Editing the mapping with the UV editor as per this video…

All looks good until I press apply, when the material goes fuzzy and rubbish. The texture and scale look alike generally though.

Similar problem to this topic… UV editor Apply changes - Rhino / Rhino for Windows - McNeel Forum

Before Apply

After Apply

beam.3dm (479.2 KB)

Any hints about doing this correctly. I’m fully aware this is very likely a pebcak scenario.

Hi @Ncik,

This is happening in the Rendered display mode due to the Advanced Texture Preview setting in the mode. You can turn this off in Options > View >Display Modes > Rendered > Advanced Texture Preview. This won’t fix the issue in Raytraced mode or an actual Render though. My preferred fix here instead would be to use ExtractRenderMesh on the polysrf. Hide the NURBS object on another layer and the mesh will look right in any display mode that shows the texture map and also the Render.

You could alternately increase the Texture Baking Quality to High in the Rendering panel > Rhino Renderer Advanced Settings. This will make the texture look less fuzzy in Raytraced and when using Render but not in the Rendered display mode. You’ll also have to wait for the textures to bake with this method which is why I prefer the ExtractRenderMesh method instead.

This area is getting some love in Rhino 8 development so I’ll make sure the devs see this case too. I think it has to do with the number of times the texture is repeated and the size of the polys in the unwrapped UV mesh.

By the way, I have a more recent texture mapping video up here if it’s useful.

Thank you @BrianJ. Perfect.

The shoe video is my next step.