Rhino6 - viewport rendered mode problem

I’ve been through this before, seemed solved, but it’s not.

  • Flamingo 5.5
  • rendered view has been restored to default (it solved the problem with other model)
  • no Raytracing, no special setting
    Why am I getting this black image?
    What am I doing wrong?
    Thanks for your help.

Hello - what is providing the '30 mm and the ‘00000’ in the viewport?


30mm is one object on its own layer that I want to show, no special meaning
00000 is there because the view is set to start as a rotation in Bongo. If I deselect the view in the Animation Manager nothing changes

I’ve done copy/paste of the object in a new rhino file, where I have experienced that rendered viewport works ok.
Problem may lay in the material, as you see in the pic. But it renders great in Bongo etc. Box is the only object without material applied

Tried to give a color to the box, just a flat color. Should be salmon color now

Hello - I would check how it works if Bongo is disabled and Rhino closed and reopened.


Here it is.
No Bongo Timeline, no Animation Manager, no animation at all.
Settings for rendered viewport restored to default
Saved + opened again.
Screw is an object cut/paste from an animation I did + a cone and a box I created on the spot.
Box has an orange Flamingo color that is not coming out on rendering



render test_01.3dm (2.3 MB)

Hello - it looks like you have a material from another renderer, other than Rhino render, Thea perhaps, on those objects.


You have to change rendering settings and set the flamingo environment as bg… rf. The render mode viewport will be change.

Hi Pascal,
I messed a little with Thea at the beginning of this project, but this is quite a later file, just refers to that material that is all Flamingo made.
Orange box wasn’t in the right layer, that’s why it was off. My fault.
I tried to find out anything about having a thea material on, but I did find nothing.
Screw refers to layer for material.

And here I moved CONE and SCREW on new layers and given the material directy to the cone. No material on layer

Hi foreigner,
tried that, at no avail. Quite weird thing going on, as the other day I started a new project and after restoring settings to default, rendered viewport worked perfectly.
This is what I am getting changing the bg (before it was solid color/white).
Orange now comes out ok because I had the box on the wrong layer, my fault.

The problem is : a Flamingo environment not support HDRI background on render viewport mode … only BGcolor.

I see what you mean, but I have no image as a backdrop, only a SOLID WHITE, please see the settings.
And turning off the HDRI skylight this is what I end up getting.
But my point is that objects with a MATERIAL don’t get rendered in the Rendered Viewport.
The ball has the simples material of all METAL from Flamingo, right out of the box, no extra image (while the cone has one) but same bad stuff in the end.
Strange as I have files created in Rhino 5 where (although not rendered very well), the bitmap on the material shows reasonably well.

Ok i know what you are meant, but now when i switch my render engine to v-ray and add some vrmat it’s working then back my render engine to flamingo all materials are corrected.

So if you want to use 360 Environment forget flamingo environment use basic environment then assign it with hdri the same using in flamingo.

1 Like

Try with this test viewport rendering mode is working fine here, “only one bug in Flamingo environment Image/HDR not appear effects in Viewport rendering mode”.

Test.rar (2.1 MB)

I tried the basic evironment, and this are the results.
Actually, about the environment I use the most basic possible:
-white background

  • no lights
  • only the hdri sky, nothing else.
    But what I see is that every objet that has a Flamingo material, is simply not appearing. All the rest is fine

downloaded you your file but is not opening, can you please post it again?