Rhino6/Grasshopper+VisualARQ2.1=Many errors


#1

Hi all, I installed VisualARQ Elevation for Rhino6, and after many hours of trying, I ended up with this:
-Rhino 6 got much much much slower comparing with VisualARQ/Rhino5.
-In some points several times Rhino 6 just stop running without any error window.
-I got this Grasshopper error window each time I run Rhino 6.
-The Hidden Display mode isn’t really hidden as I can still see the grids in VisualARQ Objects.
-Raytraced and Render mode are way worse than it used with VisualARQ Objects, plus it hangs many times in Raytraced mode.
-Rhino6 Hangs when using the Furniture Objects.

P.S I felt Rino5/VisualARQ was mush better than Rhino6/VisualARQ( Considering all the cool new features in Rhino 6.Capture

System Info:
Rhino 6 SR4 2018-4-10 (Rhino 6, 6.4.18100.1591, Git hash:master @ b6485d60ae29d5ee76751120dc9232f8b172e934)
Licence type: Evaluation, build 2018-04-10
License details: Stand-Alone
Expires on: 2018-05-12

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: THEENDS

GeForce 840M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.01)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2018
Driver Version: 23.21.13.9101
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\ColorPicker (336da4ab-03d3-42ca-b1fb-313bfd4c1157)\2018.2.5.819\ColorPicker.rhp “ColorPicker”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\LENOVO\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Rhino 3DM File Version (aa091cb2-d8c0-4944-a17d-b66c80bec4ca)\6.0.0.0\RhinoFileVersion.rhp “Rhino 3DM File Version”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “Mesh2Surface”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.4.17.851\SectionTools.rhp “SectionTools”


(Enric Marquès) #2

Hi @Elshar,

I’ve installed the same version of Rhino 6, and I don’t get these errors. There is another user that has the same problem (Grasshoper Error when open rhino 6), and he has some Grasshopper add-ons installed. I think that maybe VisualARQ Grasshopper Components have some compatibility issues with one of them. Can you please tell me which GH add-on do you have installed so I can try to reproduce the issue here?

This is really strange. VisualARQ 2.1 should be as fast (if not faster) on Rhino 6 than on Rhino 5. Does it happen when working with VisualARQ documents or with any kind of document? Can you describe what is slow? The display? Running commands?

What do you mean by “just stop running”? Rhino windows closed without showing the crass dialog?

Do you have a document where you’re seeing this error? Does it happen with all documents? Does “Technical” diaplay mode work fine?

Yes, we’re aware of a problem related to the Raytraced display mode, and we’re currently working on a fix. Rendered display mode should works fine, and even better than in Rhino 5. Can you show what problems do you see in Rendered viewports?

I think this problem may be related to the Grasshopper errors you’re getting when VisualARQ / Grasshopper loads.

Thanks,

Enric


#3

Well, probably! Well I have many adds-on Grasshopper includes:
-Human UI
-Heteropetra
-Heliotrope
-Pufferfish
-PanelingTools
-Kanagaroo2
-Gismo
-Human
-LunchBox
-Quelea
-Crystallon
-Elefront
-Anemone
-TT Toolbox
-Extra
-Honeybee
-LadyBug
-Vray3.6
-VisualARQ
#In the componants folder of grasshopper in Rhino 6 I have T-Splines adds-on while the plugin installed in Rhino 5.
#P.S I cannot seem to run Grasshopper from inside Rhino 5 anymore, as the command results with unknown.
While the Plugins installed in Rhino 6 include:
-Vray
-VisualARQ
-Mesh2surface
-PanelingTools
-SectionTools
-Color Picker
-Rhino Polyhedra
-Rhino 3DM File version

Yep,Rhino windows closes without showing the error dialog.

It does happen with all the documents. Yes, the Technical display mode works fine.

Is not easy to handle the model in Rendered mode, with the environment change properties and the level of the model.


(Enric Marquès) #4

Wow! That’s a big list of add-ons. It could take some time until a can get and install all of them. Do you have the exact version number of each one?

I don’t see any problem in this image. Do you mean that you’re seeing the viewport grid over the objects? If yes, this is not a bug, this is on purpose.

Hidden (and Technical) display modes hides lines from other objects, but not the grid.

This worked the same way in Rhino 5. “Technical” display mode in Rhino 5 also shows the grid, but in Rhino 6, grid is disabled by default. You can enable it under the “Display” tab.

Sorry, I don’t understand the problem, as the capture seems fine to me. Can you please try to describe it? What is not working? Is there anything that is different when using VisualARQ objects or Rhino native objects?

Thanks,

Enric


#5

Hi Enric, I believe it has something to do with Vray for Rhino 6. As I removed all the adds-on except Vray, and I still got the error window. However, when I unloaded Vray, to see if VisualARQ will start normally. I ended up with Rhino 6 crushing every time I attempt to start Rhino 6. I sent the error report to Mcneel. Now how can I solve this?


(Enric Marquès) #6

I highly doubt anyone at McNeel will check this error now. Can you please zip and send me to visualarq@asuni.com the “RhinoCrashDump.DMP” (not 3DM) file that will appear on your desktop when you try to start Rhino 6? Take into account that this file will dissapear when you close the report dialog, so rename it or make a copy before closing the dialog. I’ll check it and see if I can tell you what’s going on.

Thanks,

Enric


#7

Where can I find the RCD.DMP?
I only get this 11


(Enric Marquès) #8

The file will appear on your Desktop folder. If you don’t see it, press F5.

Enric


#9

Hi Enric, Sent!


(Enric Marquès) #10

Hi Elshariff,

According to the DMP, the crash is happening inside the code of a DLL called “VRaySDK.Net.DLL”, which I think is from V-Ray.

Did you uninstall V-Ray or you disabled it in the plug-ins panel?
If you disabled it, I think that when Grasshopper tries to start, it tries to load the VRay add-on, and as the RHP is blocked, the add-on may fail to load and crash.

I’m now downloading V-Ray 3.6 for Rhino 6 and I will start investigating why VisualARQ is incompatible with it. I hope I can solve the problem this weekend, but maybe the fix will need also changes also from ChaosGroup…

In the meantime, if you really want to use VisualARQ under Rhino 6, you can try to rename the V-Ray addon .GHA file to .NOGHA, so Grasshopper will skip it when loading add-ons.

Enric


(Enric Marquès) #11

Hi Elshariff,

I’ve installed V-Ray 3.6 in my Rhino 6.4, and I don’t get the errors, so I don’t think this is a problem between VisualARQ and V-Ray.

Have you tried to uninstall V-Ray and see if you still get the errors without any Rhino plugin or Grasshopper add-on loaded?

Enric


#12

Hi Enric,
I have just uninstalled V-Ray while all the other add-ons and plugins still installed. And HOLLA, I did not get the error window anymore!
VisualARQ works fine too :slight_smile:


#13

Reinstalled V-Ray, and it worked fine this time with no error window. Don’t know what happened!


(Enric Marquès) #14

Great!
The problem is that don’t know what was causing your GH errors.
When you reinstall V-Ray in Rhino 6, please, let me know if the issue appears again.

Is Rhino 6 still slow?

Regards,

Enric


#15

Hi Enric,
No Rhino 6 is not slow anymore. It works fine.
V-Ray installed and worked fine too.

But I noticed something it could be the issue I do not know.
When the error window used to appear, I noticed that Grasshopper load at the beginning at the same time as Rhino 6 window load. which was strange and I don’t why I didn’t mention this before (Maybe I thought it’s okay).
However now after the error window stopped, grasshopper only load when Rhino window completely open and I press one of the VisualARQ tools.
And I guess this what makes run slow then at the beginning.
Probably,
Anyway All the Best Enric


(Jperick1) #16

Overall, I am enjoying the new ViaualARQ however, I have a similar experience with VisualARQ crashing Rhino 6. I do not have, nor have had V-Ray installed. I do have Brazil and Bongo plugins as well as several grasshopper plugins. When starting Rhino, a list of grasshopper errors will appear (see attached txt file), several of which name the Clipper Components plugin as having some issue. The Clipper Components plugin will not properly load despite several uninstall/reinstall attempts.

GH_Load_Ex.txt (3.7 KB)

Running Rhino 6 with VisualARQ does feel slightly more sluggish than running Rhino without the plugin. Rhino also appears slower in updating the graphics of ViaualARQ components and misses some objects while in shaded mode. Technical mode appears to work fine.


(Enric Marquès) #17

Hi @Elshar and @jperick1 ,

I’ve found and fixed the bug!

Here is an explanation about the bug:

And here is the installer for the latest WIP build of VisualARQ 2.1.1:
https://visualarq.s3.amazonaws.com/download/visualarq-2.1.1.12217-rhino6-setup-snapshot.msi

Please, test it and let me know if you still see errors when loading VisualARQ or Grasshopper. My plan is to publish it later today if there are no issues.

Thanks again for your patience and your help!

Enric


#18

Hi! I dont know, if this is relevant comment here, but I have just noticed a display error in rendered (and others) display views using skylight and shadows. There are some shadow fragments when using clipping plane. This happens only with VisualARQ loaded to Rhino 6. See picture bellow.


#19

Hi Enric,
I have downloaded and tried the WIP version, and it works pretty fine. No errors appeared when loading VisualARQ nor Grasshopper. And it appears to be slightly faster in Rhino 6 than the 21.0 version.

As @petumatr mentioned above, I don’t have the shadow fragments when using clipping plane, but I do noticed that VisualARQ objects appears to have some issues when using clipping plane in some display modes:
-Raytraced display mode: Clipping Plane ignores all VisualARQ objects.


Arcitic Display mode: Clipping plane does cutting through the VA Objects, but it ignores some.

Rendered & Hidden Display modes: Clipping plane does cutting VA Objects but it appears to be like a mirror I don’t know.

The other display mode are just working fine displaying the cutting objects.


(Wim Dekeyser) #20

Just a quick note on Raytraced, that display mode doesn’t support clipping planes as of yet.