Crashes inserting First Floor WIndows in Villa Savoie Tutorial. Dead end?


(Djhg) #1

By about the third copied and pasted window at about the 4th minute mark of Tutorial video 2.6.1, Rhino crashes on me every time. This has happened repeatedly for over an hour. Maybe Rhino6/VIsualArq2.1 isn’t stable enough to use, unless anyone has a recommendation of what to check which might be causing this. From what I can tell all is set up as should be from the tutorial. I got this far and everything has turned out as it should.

Rhino almost never crashes, but it crashes a lot using Va.


(Enric Marquès) #2

Hi @djhg,

Can you please zip and send me the model to visualarq@asuni.com just before trying to do the copy and paste operations? I need to reproduce the crash in order to fix it. I’ll take a look as soon as I get it.

VisualARQ 2.1 for Rhino 6 is almost a new plug-in, as Rhino 6 SDK has changed a lot, specially how Rhino handles document objects. It took almost 6 months of development just to port the code from Rhino 5 to Rhino 6, without adding new features. We tested it intensively, but we already expected some crashes with the first version as it is impossible to test all situations, computer configurations, etc. We’re currently working very hard to stabilize VisualARQ 2.1. VisualARQ 2.1.1 was released last week and VisualARQ 2.1.2 is also going to ship next week with all reported bugs (some of them crashes) fixed.

Thanks,

Enric


(Djhg) #3

Thanks Enric. I have sent the file and a brief list of other crashes, only one other of which (relating to curving glass and faceted curtain walls) seems consistent. BTW I am using Version 2.1.1.12222
david


(Enric Marquès) #4

Hi @djhg,

Received! Thanks DG!
I’ll let you know as soon as I have more information.

Are you sending the crash reports to McNeel? Are you including your email or name in those reports, so I can identify them? If the crash is caused by VisualARQ, I’ll get the report from McNeel.

Thanks again,

Enric


(Djhg) #5

I only sent the first few to Mcneel. I will send any more.

DG


(Djhg) #6

And yes, my name was attached to the first of them.


(Enric Marquès) #7

Hi @djhg,

Good news! I’ve found the problem and I’ve fixed it, thanks to the last DMP file you sent. Here is the latest WIP build of VisualARQ 2.1.2 that includes this fix (and some other bugfixes):
https://visualarq.s3.amazonaws.com/download/visualarq-2.1.2.12223-rhino6-setup-snapshot.msi

Please, let me know if this version works better and is not crashing anymore inserting the window copy.

Thanks for your patience,

Enric


(Djhg) #8

Thanks Enriq. I’m very glad. I’ll let you know how it works now.

David


(Djhg) #9

Wow! Fixed within 2 1/2 hours of my getting the Crashdump file to you. Very impressed. This bodes very well.
thanks again
David


(Enric Marquès) #10

Usually, fixing a crash when you can reproduce it or you have dump that points to the exact line on the source code where the crash happened helps a lot.

I’m glad this version works better for you.

Thanks again for you help!

Enric