Rhino5 is suddenly not working anymore


I installed Rhino5 several years ago. At the moment the 64 bit version, which I always use has problems, safe mode and 32 bit versions are working fine.

  • When the 64 bit Rhino starts up the viewports appear very slowly, one by one.
  • Every action has a long delay on the screen, when I draw for example a rectangle, it appears after some time in the first viewport en later in the next, etc.
  • It is impossible to work with.
  • When I make a printscreen, the screen layout is normal, the problem is invisible on a picture.

I use Rhino often, but my projects are not very complicated. Technically I am a dummy. I hope there is a simple solution.

Has anybody an idea? Thanks in advance for your help!

What are your computer specs and your OS? Have you updated your video driver? Is Rhino up to date?


It sounds like you have an inadequate display adapter/driver combination.
Try this:
In Rhino Options > View > OpenGL, uncheck the top option for using accelerated hardware modes.

Any better performance?
If so a driver update might get you going.
Mitch is right, we need your computer specs. to have a better guess.

What have you changed in between the last time it ran OK and now? Or what has Microsoft changed for you, perhaps without your knowledge?

Thanks you all for the fast reply and your advice! Rhino5 64 bit is working again with John’s suggestion.

  • Rhino: Version 5 SR14 64-bit (5.14.522.8390, 22-5-2017), commercial. Recently I received an update. I never downloaded an update myself.

  • OS: Windows10

  • Processor: Intel® Core™ i5-2500K CPU @3.30 GHz 3.30 GHz; x64 processor

  • No sepereated video card

  • RAM: 16.0 GB (15.7 GB available)

I never updated the processor driver. Do you think this might help to work in 64 bit mode again?

A week ago there was indeed a big Microsoft update. Installation took 40 minutes or so. It could have been the start of my Rhino problem, but I am not 100% sure.

No, I think it’s display adapter/driver related.
Run the Windows Device Manager > Display adapters
What do you have and what is the date of the driver?

I hope this screenshot gives you the information you asked for.

‘installatie van apparaat vereist’ means: device installation required.

Right. The old Intel HD 3000 and earlier chips are not supported. The slightly newer 4000s sort of work but not well.
The only way to run Rhino is with the accelerated hardware modes turned off.
My guess is some update that was run turned it back on and caused the problem.

That has to be a pretty old system,
When you get around to replacing it, please choose a display adapter with good support for OpenGL.

Thanks John for the diagnosis. I’m happy there is a way to work further, but I need to learn about OpenGL.

Yes, my system is about 8 years old. Because my projects are not to complicated (relatively short render times), the limitations were never constraining. My younger brother build the computer and it never failed. It has a nice Fractal case and is totally silent. I am devoted to my old system :slight_smile:

Rhino V5 will run as long as the accelerated hardware modes are disabled.
The installer is supposed to automatically turn it off and I’m sure it’s been off all this time. The mystery what what changed that turned it on.

If it happens again, at least you’ll know what to do.

Basically, there are three types of Windows graphics:
GDI - Basic display
DirectX - Gaming
OpenGL - Workstation

You Intel HD 3000 is good at GDI display and uses very little power. It’s not good for DirectX or OpenGL.
Rhino uses OpenGL display. That’s why we tell people to choose a display adapter that has good OpenGL support.