Rhino 5 (64-bit) SUPER slowly


#1

Hi, I am new to this community so thank you for your responses in advance.

I am running Windows 10 via bootcamp on my 2012 macbook pro. When I open any rhino file no matter the size in the rhino (64 bit) icon my scrolling, zoom and any commands are incredibly slow. We’re talking about 10-15 seconds of lag time before it completes. Once it completes I am able to hover over items on the menus and there is no lag. It’s just when I execute any command or movement. The weird thing is that when I open a file using the other icon that was downloaded when I downloaded rhino, it all works fine. What is this? I am not terribly experienced with computers and their inner workings but I knew little enough to upgrade my ram to 16 gb and replace my optical drive with a secondary internal hd while upgrading my primary drive to a 500 gb solid state. All other programs run smoothly and quickly. Thank you
-P


(John Brock) #3

I’m sorry you’re having problems.
Pursuant to gathering more information on this problem, have your tried the V6 WIP?
Does is perform like 32-bit V5 or slowly like 64-bit V5?


#4

Hi, thanks for the reply. I have not yet tried the V6 WIP. The other icon that downloads with the rhino download loads easily, though. I am now trying to figure out what’s going on with my Maxwell plugin but I think as long as this version holds up, I’ll keep using it. I will definitely be trying the V6 WIP.


(John Brock) #5

The “other” shortcut is for 32-bit V5. It will run plugins compiled against the same tools V4 used. It’s the same as 64-bit except it only can use 4gb RAM.
I may have a work around for you but I need to know if V6 works or not.
Thanks


#6

Hi John,

Thanks. I have downloaded the V6 WIP and I really like it. The raytrace view is pretty cool and the quality of the other views seems better. I also like the GH icon and render side-bar. So it runs nicely but seems a slight slower than V5. Perhaps it runs slower because it has more features. It does work though. Any idea why my V5 may be being weird?
Thanks
-P


(John Brock) #8

That’s good news about V6.

Try this for the V5 64-bit:
In Options > View > OpenGL, try unchecking the top option for using accelerated hardware modes.

Does that speed things up again?


#11

Yes, it’s been very usefull for me:) Great thanx…


(Grant Herron) #12

Thank you for the tip! My power supply recently died, and it took my graphics card with it. I haven’t gotten around to purchasing a new card yet, and I had forgotten about this little setting. Rhino 5 wouldn’t function at all! Rhino 6 WIP was working totally fine.

This was a life-saver.


#13

Hey, I was having this crazy slow performance after upgrading windows 10…
I downloaded the most recent version of Rhino 5 and reinstalled - seems back to normal now!
Cheers,


(Kentdesautel) #14

Hi John,
I am experiencing similar problems on V5 64bit where all of a sudden Rhino will start running slow trying to open files and even navigating the menus with no file opened at all. I’m starting to think it may be windows 10 updates that are causing my problem… because Rhino will work fine for months on end… and then all of a sudden it will start acting up.

Anyway I did try your suggestion on unchecking the using accelerated hardware mode and that seemed to fix the issue.

What is that option used for?

Thanks,

Kent


(John Brock) #15

When checked, that option sends the display instructions to the display adapter driver. If the adapter and driver have been written to support accelerated OpenGL, then you will get better performance and more responsive display performance.

If the display system chokes on the instructions, then poor performance is the symptom.
In that case, for V5 it’s better to disable that option so Windows software emulation does the display work.
The key is to choose a display adapter INTENDED for accelerated OpenGL when you purchase the computer.