Rhino Zoom

Hi guys

Does anyone know how to set the settings to automatically zoom in to pasted objects?
When I copy/paste objects from a different rhino file to another file, it will place the object at random location which I have to use zoomselected command to locate copied objects.
Is there a way to automatically zoom into copied objects when you copy anything to your file?

Thank you

Hello- - it is not random, it is the location in the originating file. You can make a macro

! _Paste _ZoomSelected

-Pascal

How do you make a macro?

Thank you

Hello- I made one for you - you can copy

! _Paste _Zoom _Selected

to the clipbpoard and paste to the Rhino command line to see how it works.
Add it to a button or alias would be the more common way to use a macro

https://docs.mcneel.com/rhino/8/help/en-us/index.htm#information/rhinoscripting.htm?

https://docs.mcneel.com/rhino/8/help/en-us/index.htm#options/aliases.htm?

https://docs.mcneel.com/rhino/8/help/en-us/index.htm#commands/macroeditor.htm?

-Pascal

Thank you so much!
Do I have to set any command button for this macro? like which key should I put in place of “NewAlias”?
image

Hello - You can put any combinations of letters in there - whatever makes sense to you ‘PasteAndZoom’ for example. Note aliases require an Enter - you can put the same macro on an F-key in the Keyboard section of Options, these do not require Enter to run.

-Pascal

Thank you so much!
I put the alias in and tried coping an object and it still won’t zoom into copied object

Hi -

Please run CommandHistory, copy the last few lines, and paste that data here.
-wim

Like these few lines are good?
image

Hi -

Thanks.
There are 3 things that strike me here.
(1) you are copying and pasting in the same file? Since you need to select something when you copy, the viewport should already show the geometry. Are you panning away between copying and pasting?

(2) you are running ZS. That is fine, but, to make sure, did you modify the macro after posting a picture of it?
image

(3) the command feedback shows that Rhino successfully zoomed to the selected geometry. If nothing were to be selected, the feedback would be:

Command: ZS
Command: '_Zoom
Drag a window to zoom ( All Dynamic Extents Factor In Out Selected Target 1To1 ): _Selected
Unable to zoom - no objects are selected.

When the macro finishes, can you use Ctrl+C and then paste into a reply here? That will paste a picture of the active viewport and hopefully give us a better idea about what is going on.
-wim

Thank you for your response.

So that Zoom Selected is what I typed in after coping an object from another file.
So let’s say I am at the origin in my rhino file and I copy this object from a different file that is not at the origin. When I paste that object into my current file I will still be looking at the origin and not knowing where my copied object is so then I have to type in zoom selected to find that object to properly place it where it needs to be.

Hi -

Why didn’t you use the macro?
I can’t tell from your answer if you ended up with the selected geometry centered in the active viewport…
Can you record the screen and post a video?
-wim

I am coping objects from a different file to another file and it won’t center the copied object in the viewport. Sorry I don’t have screen recorder so can’t really record the screen…
Can you tell me how I can use the macro so that it automatically centers the copied object from another file in the active viewport when pasted into another file?

Thank you

Hi -

In Rhino Options > Aliases, I created the following alias:

testing123      _Paste _ZoomSelected

In file A, I have a rectangle.
I switch to file B, select all objects and use Ctrl+C to copy those to the Windows clipboard.
I switch back to file A, and run the testing123 command.

2024-04-12 - Paste and Zoom2

-wim

1 Like

Ahhh I see. So rather than doing ctrl + v when pasting, I need to type in the actual macro command.
Thank you so much for your brief explanation! Thank you so much!!!