Rhino Wip - Clipping plane and Make 2D problems

Hello,

I recently started working in Rhino Wip with a model. In rhino 7, to cut a plan or section of a model, I used to use the clipping plane and then align the C-Plane to the model. Then to get the drawing in Lines, I used the Make 2D command with selected options- scene silhouette, clipping plane intersections and sometimes group output. This way I used to get the drawings which I needed.

I tried to go the same thing in Rhino wip but the Make 2D only includes part of my model. I have attached pictures of how the Make 2D looked like in rhino 7 and rhino wip.

How the model looks in rhino wip from Top view:

Make 2D in Rhino 7:

Make 2D of the same model in Rhino wip:

Also, I read the updated features in rhino wip and clipping plane is one of them. My layers panel should have a column named “clip” which I can’t find or add in my existing layers panel. I don’t know if that has anything to do with my Make 2D problem.

Snapshot of how my layers panel looks:

Hi Saakshi -

I’m not able to reproduce that issue in a quick test here. Could you post or upload the 3dm file (or some of the objects that you are having problems with).

In earlier WIPs, clipping plane participation was set on objects or layers. This has been changed to be set on the clipping plane. Select a clipping plane and look in the properties panel to include or exclude objects or layers.
-wim

Here’s the rhino wip and rhino 7 file:

06.20 Updated Copper house II_model - rhino 8 edited.3dm (15.9 MB)

06.20 Updated Copper house II_model edited-rhino 7.3dm (15.3 MB)

Is there any update on the clipping plane problem @wim?

Hi Saakshi -
I can see the issue in the model that you posted, yes, but I’m still trying to narrow it down to try to find what makes this happen. I’m running into a bit too many issues on my old Mac here, so that’s taking its time…
-wim

1 Like

Hi Saakshi -

It looks like Make2D is not liking the display meshes of the objects.
When you run ClearAllMeshes and then run Make2D, the result seems to be as expected. When you then put the viewport back into a shaded mode, Make2D will fail again.

I’ve put this issue on the list as RH-75508 Make2D: Failure case
-wim

Thank you so much @wim! For what I am trying to do, ClearAllMeshes and then making 2D is what I needed for now.

Thank you again for working on this and helping me!

1 Like

RH-75508 is fixed in the latest WIP

Hello @wim
I’m noticing something from the last couple of builds.
Mesh (Any Mesh) + Clipping plane (any clipping plane) won’t show any results with MAKE2D.

In the screencap video below, you can see only the viewport rectangle has been captured by MAKE2D

Thanks, Tay.
I went back to an old build that is 2 days away from expiring and the same thing is happening in that one, so this bug was introduced quite some time ago.
RH-76378 Make2D: No output from clipped mesh
-wim

1 Like

thank you @wim
I see on YT that the problem has been solved, although on today’s build it is not yet resolved.
Update : It works on other display modes, just not the shaded one.

Hi Tay -

Did you test this with the “MeshSphere for Make2D.3dm” file that is attached to RH-76378?

As you might have read in that YT item, this issue seems to be very file and view specific. If you are testing anything else than that exact view in that specific file, I’d need a 3dm from you with a named view that doesn’t behave.
-wim

Hello @wim
yes I tested that on the sample 3dm attached in the YT

1- No output from the shaded mode (or arctic, ghosted)

2- I get an output of the silhouttes when running the command in the wireframe mode.

Hello Again @wim
Testing today’s build Rhino 8 SR0 2023-10-3 (Rhino 8 BETA, 8.0.23276.13303)
Nothing is working, even the wireframe mode doesn’t provide any output from a clipped mesh.

Hi Tay -

I took a closer look at the videos you posted and it appears that you are using a modified view. As I wrote earlier, this seems to be very file and view specific, so I’d need to get a file from you with that exact view saved as a named view.

Apart from that, have you also tested this with 3rd party plug-ins disabled?
-wim

Hello @wim
I did the steps below:
1- Factory Reset Rhino using the “Reset” command
2- Disable all 3rd Party Plugins
3- Restart Rhino
4- Open the file " MeshSphere for Make2D.3dm" that is attached to YT RH-76378
5- Navigate to the named view " View_for_Make2D"
6- Run the Make2D command with the settings below:

Still no output from the clipped mesh other than the viewport’s rectangle.