Rhino script compiler - installer installs for both Rhino 6 and 7. How to control that?

Hi guys, I have updated Holomark2_R6 so it runs fine on Rhino 6, but when I compile the script into an installer then the installer installs Holomark for both Rhino6 and Rhino7 (wip).

How can I control it so it only installs for Rhino 6?

Does it run under V7? If so, why not just keep it. Might provide a good tool to keep the V7 developers on their toes. :wink: Not that they need it, of course.

1 Like

Good point, but I expect them to change the code as development progresses and that will force me to keep my code updated. And I’d rather spend that time on Holomark3 :slight_smile:

Hi guys, why does this come up?
@dale is this for you?

I tried to install the Holomark2_R6 plugin that I compiled today…

FYI: I used a Rhino6 RhinoCommon.dll when I compiled to avoid the V5 installation.

Hi @Holo,

The message is pretty descriptive.

– Dale

It probably is but obviously not to me…
Why do you think I ask for help?

It installed just fine on one machine and not on an other.
So any help would be great!

First of all, what is a GUID and what is it refering to?

Hi @Holo,

Each plug-in must have a GUID for identification, and this GUID must be unique. For example, you can’t load two different plug-ins into Rhino 6 if they both have the same GUID. A GUID looks like this: 7E3B6EE4-D3F9-46ED-8F21-0ADFFCA6AE0D. If a single installer (RHI) installs several plug-ins (i.e. one for v5, one for v6 and one for WIP), then all those plug-ins need to have the same GUID.

I’m not really sure why this is, but that’s how I interpreted the installer message.


Ok, thanks.
I still don’t get it though as the installer is from the compiler and has only one script in it :confused:
So why it throws an error on the laptop surprises me. I made an earlier version of holomark for v6, but that one had a different name and I started a new project in the compiler too, so why it thinks Guid’s are in conflict is beyond me.

@Holo I don’t know either. I’m assigning this to @brian, he might know more. @will Do you know anything about this?


Hi @Holo,

If want full control to which Rhino version your plugin is installed, do not create an rhi installer file with the compiler. Just create one rhp plugin file. Then follow this guide and make only one folder for Rhino 6 below your Holomark folder. Put your plugin inside this folder. Then zip it. Once done, rename the extension to rhi to get the installer.

btw. one more tip, before trying this all out, make sure you remove any old installed plugins and close Rhino before running the installer.


1 Like

Unfortunately it’s the individual .rhp files that are examined by the Rhino Installer Engine, not the folder structure.

We took the decision when Rhino 6 was released to install .NET plug-ins compiled for earlier versions of Rhino in all later versions. This only happens where the plug-in is found to be compatible based on a quick check at install time. A more thorough check also happens at load time. The idea is that, since we’ve put in a lot of effort to keep the RhinoCommon SDK backwards compatible across versions we should allow users to load their existing plug-ins without waiting for the developers to recompile them. I’m not sure if this approach is appropriate for plug-ins compiled with the script compiler, however. Let me have a think and get back to you…

David’s explanation of the error message is correct. The .RHI format was intended to contain multiple versions of a single plug-in, not multiple different plug-ins.

1 Like

But that’s what I don’t understand because I didn’t make multiple plug-ins. I only made one, and it worked on my and milezee’s workstations but not on my laptop. Do you want the plugin?

Sure, send it over and I’ll take a look. Thanks!

Hi @will,

my answer above was meant only for the case in the OP which is about a single rhp file. I’m curious @Holo, did you try to make only one folder for Rhino 6 and did this then still install in RH7 ?


Nice, just tried it and it seems to work. Installed nicely on Rhino 6 on the laptop, but I don’t have the WIP on this one though. But no GUID issues when I did it like that.

1 Like

Thanks for the feedback Jørgen, it is what i expected and hopefully it also works when the WIP is installed on the same system. If not it may be a bug in the installer.

Hey folks, I’ve tried to tidy up the Rhino Installer Engine docs here to properly explain what happens when we try to install a .rhi file.

@Holo – I checked out the file you sent me and couldn’t see any issues. What versions of Rhino are installed on the machine that was complaining about mismatched GUIDs?